PAT Advanced 1002 A+B for Polynomials

1002 A+B for Polynomials

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N1 a**N1 N2 a**N2 … N**K aNK

where K is the number of nonzero terms in the polynomial, N**i and aNi (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤N**K<⋯<N2<N1≤1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

      
    

Sample Output:

3 2 1.5 1 2.9 0 3.2

解题思路

模拟多项式相加的过程, 指数相同的系数相加。 使用hash的思想, 下标指数对应系数相加。

解题代码

#include <cstdio>
using namespace std;
const int N = 1010;
double exp[N], b;
int n, a, cnt;
int main(){
    for(int i = 0; i < 2; i++){
        scanf("%d", &n);
         while (n --){
            scanf("%d %lf", &a, &b);
            exp[a] += b;
        }
    }
    for (int i = 0 ; i < N; i++){
         if ( exp[i] != 0) cnt ++;
    }
    printf("%d", cnt);
    for (int i = N; i >= 0; i--){
        if (exp[i] != 0)
            printf(" %d %.1f", i, exp[i]);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值