HDU-置换群

79 篇文章 0 订阅

问题及代码:


/*  
*Copyright (c)2014,烟台大学计算机与控制工程学院  
*All rights reserved.  
*文件名称:HDU.cpp  
*作    者:单昕昕  
*完成日期:2015年1月27日  
*版 本 号:v1.0  
*问题描述:As a unicorn, the ability of using magic is the distinguishing feature among other kind of pony. Being familiar with composition and decomposition is the fundamental course for a young unicorn. Twilight Sparkle is interested in the decomposition of permutations. A permutation of a set S = {1, 2, ..., n} is a bijection from S to itself. In the great magician —— Cauchy's two-line notation, one lists the elements of set S in the first row, and then for each element, writes its image under the permutation below it in the second row. For instance, a permutation of set {1, 2, 3, 4, 5} σ can be written as:
<img src="https://img-blog.csdn.net/20150127221620625?watermark/2/text/aHR0cDovL2Jsb2cuY3Nkbi5uZXQvTUlLQVNBMw==/font/5a6L5L2T/fontsize/400/fill/I0JBQkFCMA==/dissolve/70/gravity/Center" alt="" />

Here σ(1) = 2, σ(2) = 5, σ(3) = 4, σ(4) = 3, and σ(5) = 1.
Twilight Sparkle is going to decompose the permutation into some disjoint cycles. For instance, the above permutation can be rewritten as:
<img src="https://img-blog.csdn.net/20150127221734621?watermark/2/text/aHR0cDovL2Jsb2cuY3Nkbi5uZXQvTUlLQVNBMw==/font/5a6L5L2T/fontsize/400/fill/I0JBQkFCMA==/dissolve/70/gravity/Center" alt="" />

Help Twilight Sparkle find the lexicographic smallest solution. (Only considering numbers). 
*程序输入:Input contains multiple test cases (less than 10). For each test case, the first line contains one number n (1<=n<=10^5). The second line contains n numbers which the i-th of them(start from 1) is σ(i). 
*程序输出:For each case, output the corresponding result. 
Sample Input
5
2 5 4 3 1
3
1 2 3
Sample Output
(1 2 5)(3 4)
(1)(2)(3)
*/
#include<cstdio>
#include<cstring>
#include<iostream>
using namespace std;
const int MAX=100000;
int main()
{
    std::ios::sync_with_stdio(false);
    int n,i,j,k;
    int a[MAX];
    while(cin>>n)
    {
        for(i=1; i<=n; i++)
            cin>>a[i];
        for(i=1; i<=n; i++)
        {
            while(a[i])
            {
                cout<<"("<<i;
                j=a[i];
                a[i]=0;
                while(a[j])
                {
                    cout<<" "<<j;
                    k=a[j];
                    a[j]=0;
                    j=k;
                }
                cout<<")";
            }
        }
        puts("");
    }
    return 0;
}



运行结果:


知识点总结:
置换群。

学习心得:

就是按规律置换。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值