Description
按格式格式读入一个3位的整数、一个实数、一个字符 。
并按格式输出 一个整数占8位左对齐、一个实数占8位右对齐、一个字符 ,并用|隔开。
Input
无
Output
实数保留小数点1位
Sample Input 1
123456.789|a
Sample Output 1
#123 | 456.8|a#
Hint
多组数据
Code
#include<stdio.h>
int main()
{
int n;
double m;
char p;
while(scanf("%3d%lf|%c",&n,&m,&p)!=EOF)
{
printf("#%-8d|%8.1lf|%c#\n",n,m,p);
}
return 0;
}