POJ1390 Blocks 区间DP

Description

Some of you may have played a game called 'Blocks'. There are n blocks in a row, each box has a color. Here is an example: Gold, Silver, Silver, Silver, Silver, Bronze, Bronze, Bronze, Gold. 

If some adjacent boxes are all of the same color, and both the box to its left(if it exists) and its right(if it exists) are of some other color, we call it a 'box segment'. There are 4 box segments. That is: gold, silver, bronze, gold. There are 1, 4, 3, 1 box(es) in the segments respectively. 

Every time, you can click a box, then the whole segment containing that box DISAPPEARS. If that segment is composed of k boxes, you will get k*k points. for example, if you click on a silver box, the silver segment disappears, you got 4*4=16 points. 

Find the highest score you can get, given an initial state of this game. 
Input

The first line contains the number of tests t(1<=t<=15). Each case contains two lines. The first line contains an integer n(1<=n<=200), the number of boxes. The second line contains n integers, representing the colors of each box. The integers are in the range 1~n.
Output

For each test case, print the case number and the highest possible score.
Sample Input

2
9
1 2 2 2 2 3 3 3 1
1
1
Sample Output

Case 1: 29
Case 2: 1
Source

Liu Rujia@POJ


先将序列转化成大块序列;

用f( a , b , t )去表示从第 a 大块到第 b 大块 的最大值,t表示第 b 块后所接与第 b 块颜色相同的块,

以便方便处理最后一块到底是直接消去,还是与前面同色的块相连后再消去;

需要用记忆递归的方式来求解,否则会超时。


#include <iostream>
#include <cstdio>
#include <map>
#include <queue>
#include <stack>
#include <cmath>
#include <algorithm>
#include <cstring>
#include <string>
using namespace std;
#define INF 0x3f3f3f3f
#define M 205
typedef long long LL;
int c[M],l[M];
int p[M][M][M];
int f(int a,int b,int t)
{
    if(p[a][b][t]) return p[a][b][t];
    int res=(c[b]+t)*(c[b]+t);
    if(a==b) return res;
    res+=f(a,b-1,0);
    for(int i=a;i<b;i++){
        if(l[i]!=l[b]){
            continue;
        }
        int r=f(a,i,c[b]+t);
        r+=f(i+1,b-1,0);
        res=max(res,r);
    }
    p[a][b][t]=res;
    return res;
}

int main()
{
    int t,n,x,ca=1;
    scanf("%d",&t);
    while(t--){
        int k=1;
        memset(c,0,sizeof(c));
        memset(p,0,sizeof(p));
        scanf("%d",&n);
        for(int i=0;i<n;i++){
            scanf("%d",&x);
            if(i>0&&x!=l[k]){
                k++;
            }
            c[k]++;
            l[k]=x;
        }
        printf("Case %d: %d\n",ca++,f(1,k,0));
    }
    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值