POJ3278 Catch That Cow BFS入门

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers:  N and  K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

Source

USACO 2007 Open Silver


为求解最短路径,用BFS效果更好。


#include <iostream>
#include <cstdio>
#include <map>
#include <set>
#include <vector>
#include <queue>
#include <stack>
#include <cmath>
#include <algorithm>
#include <cstring>
#include <string>
using namespace std;
#define INF 0x3f3f3f3f
const int maxn=100000;
typedef long long LL;
int n,k;
bool v[maxn+5];
struct step{
    int x;
    int steps;
    step(int xx,int s):x(xx),steps(s){}
};
queue<step> q;
int main()
{
    while(~scanf("%d%d",&n,&k)){
        memset(v,false,sizeof(v));
        q.push(step(n,0));
        v[n]=true;
        while(!q.empty()){
            step s=q.front();
            if(s.x==k){
                printf("%d\n",s.steps);
                return 0;
            }
            if(s.x-1>=0&&!v[s.x-1]){
                q.push(step(s.x-1,s.steps+1));
                v[s.x-1]=true;
            }
            if(s.x+1<=maxn&&!v[s.x+1]){
                q.push(step(s.x+1,s.steps+1));
                v[s.x+1]=true;
            }
            if(2*s.x<=maxn&&!v[2*s.x]){
                q.push(step(2*s.x,s.steps+1));
                v[2*s.x]=true;
            }
            q.pop();
        }
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值