1009 Product of Polynomials (25 分)

1009 Product of Polynomials (25 分) Java实现

This time, you are supposed to find A×B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N1 aN1 N2 aN2 … NK aNK

where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10, 0≤NK<⋯<N2<N1≤1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 3 3.6 2 6.0 1 1.6

题目大意:给定两个多项式,并将两个多项式相乘求积。

解题思路:用double类型a[]保存A多项式,同样用b[]数组保存B多项式。先找到A多项式中的一项,然后与B多项式相乘,直至A多项式所有项都与B多项式相乘,将结果存在c[]数组中,最后按规定格式输出。

import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
public class Main {
    public static void main(String[] args) throws IOException {
        BufferedReader br=new BufferedReader(new InputStreamReader(System.in));
        String []s1=br.readLine().split(" ");
        String []s2=br.readLine().split(" ");
        int k1=Integer.parseInt(s1[0]);
        int k2=Integer.parseInt(s2[0]);
        double []a=new double[1005];
        double []b=new double[1005];
        double []c=new double[2001];
        for(int i=0,j=1;i<k1;i++){
           int n=Integer.parseInt(s1[j++]);
            double an=Double.parseDouble(s1[j++]);
            a[n]+=an;
        }
        for(int i=0,j=1;i<k2;i++){
            int m=Integer.parseInt(s2[j++]);
            double bm=Double.parseDouble(s2[j++]);
            b[m]+=bm;
        }
        for(int i=0;i<1005;i++){
            if(a[i]!=0){
                for(int j=0;j<1005;j++){
                    if(b[j]!=0){
                        c[i+j]+=a[i]*b[j];
                    }
                }
            }

        }
        int count=0;
        for(int i=0;i<2001;i++){
            if(c[i]!=0){
                count++;
            }
        }
        System.out.print(count);
        for(int i=2000;i>=0;i--){
            if(c[i]!=0){
                System.out.print(" "+i+" ");
                System.out.printf("%.1f",c[i]);
            }
        }
    }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值