【HD 3665】Seaside(dijkstra)

32 篇文章 0 订阅
5 篇文章 0 订阅

Seaside

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1562 Accepted Submission(s): 1138

Problem Description
XiaoY is living in a big city, there are N towns in it and some towns near the sea. All these towns are numbered from 0 to N-1 and XiaoY lives in the town numbered ’0’. There are some directed roads connecting them. It is guaranteed that you can reach any town from the town numbered ’0’, but not all towns connect to each other by roads directly, and there is no ring in this city. One day, XiaoY want to go to the seaside, he asks you to help him find out the shortest way.

Input
There are several test cases. In each cases the first line contains an integer N (0<=N<=10), indicating the number of the towns. Then followed N blocks of data, in block-i there are two integers, Mi (0<=Mi<=N-1) and Pi, then Mi lines followed. Mi means there are Mi roads beginning with the i-th town. Pi indicates whether the i-th town is near to the sea, Pi=0 means No, Pi=1 means Yes. In next Mi lines, each line contains two integers SMi and LMi, which means that the distance between the i-th town and the SMi town is LMi.

Output
Each case takes one line, print the shortest length that XiaoY reach seaside.

Sample Input
5
1 0
1 1
2 0
2 3
3 1
1 1
4 100
0 1
0 1

Sample Output
2

Source
2010 Asia Regional Harbin

Recommend
lcy | We have carefully selected several similar problems for you: 3661 3664 3669 3667 3666

——————————————————————————————————————————————

一道很水的模板题,就是输入很奇葩,看了半天……
注意一下输入,然后套模板。

——————————————————————————————————————————————

#include<cstdio>
#include<cstring>
#include<algorithm>
#define INF 0x3f3f3f3f
using namespace std;

const int MAX_N = 100;
int par[MAX_N][MAX_N];
int dis[MAX_N];
int vis[MAX_N];
int n;
void Dij()
{
    memset(vis,0,sizeof(vis));
    for( int i=0; i<n; i++ )
    {
        dis[i] = par[0][i];
    }
    dis[0] = 0;
    vis[0] = 1;
    for( int i=1; i<n; i++ )
    {
        int u = INF;
        int v = -1;
        for( int j=0; j<n; j++ )
        {
            if(!vis[j] && u > dis[j] )
            {
                u = dis[j];
                v = j; 
            }
        }
        if( v == -1) return;
        vis[i] = 1; // 别忘记标记 
        for( int j=0; j<=n; j++ )
        {
            if( !vis[j] && dis[j] > dis[v]+par[v][j]) // 这里更新的是新添加的点 "碰得到"的点 到 “原点 ”的距离  
            dis[j] = dis[v]+par[v][j];
        }
    }   
}
int ans[MAX_N];
int main()
{
    int S,L,M,P;
    while( ~scanf("%d",&n) )
    {
        memset(ans,0,sizeof(ans));
        for( int i=0; i<n; i++ )
            for( int j=0; j<n; j++ )
            {
                if( i == j )
                    par[i][j] = 0;
                else 
                    par[i][j] = INF;
            }
        for( int i=0; i<n; i++ )
        {
            scanf("%d%d",&M,&P);
            if( P == 1 )
            ans[i] = i;
            for( int j=0; j<M; j++ )
            {
                scanf("%d%d",&S,&L);
                par[i][S] = L; 
            }
        }
            Dij();
            int temp = INF;
            for( int i=0; i<n; i++ )
            {
                if( ans[i] != 0 && dis[ans[i]] < temp )
                temp = dis[ans[i]];
            }
            printf("%d\n",temp);
    } 
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值