PAT (Advanced Level) Practice 1102 Invert a Binary Tree (25 分)

1102 Invert a Binary Tree (25 分)

The following is from Max Howell @twitter:

Google: 90% of our engineers use the software you wrote (Homebrew), but you can’t invert a binary tree on a whiteboard so fuck off.
Now it’s your turn to prove that YOU CAN invert a binary tree!

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10) which is the total number of nodes in the tree – and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node from 0 to N−1, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in the first line the level-order, and then in the second line the in-order traversal sequences of the inverted tree. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:
8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6
Sample Output:
3 7 2 6 4 0 5 1
6 5 7 4 3 2 0 1
#include <string>
#include <iostream>
#include <vector>
#include <queue>
#define max_size 11
using namespace std;
bool isRoot[max_size];
int n, index;
struct node
{
    int v, left, right;
    node()
    {
        v = -1;
        left = -1;
        right = -1;
    }
};
node tree[max_size];
void postOrder(node &root)
{
    if (root.v == -1)
    {
        return;
    }
    if (root.left != -1)
        postOrder(tree[root.left]);
    if (root.right != -1)
        postOrder(tree[root.right]);
    int tmp = root.right;
    root.right = root.left;
    root.left = tmp;
    return;
}
void level(int root)
{
    queue<int> q;
    q.push(root);
    while (!q.empty())
    {
        int now = q.front();
        q.pop();
        if (tree[now].left != -1)
            q.push(tree[now].left);
        if (tree[now].right != -1)
            q.push(tree[now].right);
		cout<<tree[now].v;
        if (q.size() != 0)
        {
            cout << " ";
        }
    }
}
void inOrder(node root)
{
    if (root.v == -1)
    {
        return;
    }
    if (root.left != -1)
        inOrder(tree[root.left]);
    cout << root.v;
    if (index < n)
        cout << " ";
    ++index;
    if (root.right != -1)
        inOrder(tree[root.right]);
}
int main()
{
    ios::sync_with_stdio(false);
    cin.tie(0);
    cin >> n;
    string s;
    fill(isRoot, isRoot + n, true);
    for (int i = 0; i < n; i++)
    {

        cin >> s;
        tree[i].v = i;
        if (s[0] != '-')
        {
            int item = s[0] - '0';
            isRoot[item] = false;
            tree[i].left = item;
        }
        cin >> s;
        if (s[0] != '-')
        {
            int item = s[0] - '0';
            isRoot[item] = false;
            tree[i].right = item;
        }
    }
    int root;
    for (int i = 0; i < n; i++)
    {
        if (isRoot[i])
        {
            root = i;
            break;
        }
    }
    postOrder(tree[root]);
    index = 1;
    level(root);
	cout<<endl;
    inOrder(tree[root]);
    return 0;
}

在这里插入图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值