hdu 5918 Sequence I kmp算法

Sequence I

Time Limit: 3000/1500 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2364    Accepted Submission(s): 883


Problem Description
Mr. Frog has two sequences a1,a2,,an and b1,b2,,bm and a number p. He wants to know the number of positions q such that sequence b1,b2,,bm is exactly the sequence aq,aq+p,aq+2p,,aq+(m1)p where q+(m1)pn and q1 .
 

Input
The first line contains only one integer T100 , which indicates the number of test cases.

Each test case contains three lines.

The first line contains three space-separated integers 1n106,1m106 and 1p106 .

The second line contains n integers a1,a2,,an(1ai109) .

the third line contains m integers b1,b2,,bm(1bi109) .
 

Output
For each test case, output one line “Case #x: y”, where x is the case number (starting from 1) and y is the number of valid q’s.
 

Sample Input
  
  
2 6 3 1 1 2 3 1 2 3 1 2 3 6 3 2 1 3 2 2 3 1 1 2 3
 

Sample Output
  
  
Case #1: 2 Case #2: 1
 

Source
//CcpcTraining.cpp: 定义控制台应用程序的入口点。
//#include "stdafx.h"
#include<stdio.h>
#define size 1<<20
int a[size], b[size];
int nextval[size];
int n, m, p;
void getNextval() {
    int k = -1;
    int j = 0;
    nextval[j] = k;
    while (j < m) {
        if ((k == -1) || (b[j] == b[k])) {
            ++k;
            ++j;
            nextval[j] = k;
        }
        else {
            k = nextval[k];
        }
    }
}

int kmp(int temp[],int length) {
    int i = 0, j = 0;
    int sum = 0;
    while (i < length) {
        if ((j == -1) || temp[i] == b[j]) {
            i++;
            j++;
            if (j == m) {
                sum++;
                j = nextval[j];
            }
        }
        else {
            j = nextval[j];
        }
    }    
    return sum;
}

int main() {
    int test;
    scanf("%d", &test);
    for (int t = 1; t <= test; t++) {
        scanf("%d%d%d", &n, &m, &p);
        for (int i = 0; i < n; i++) {
            scanf("%d", &a[i]);
        }
        for (int i = 0; i < m; i++) {
            scanf("%d", &b[i]);
        }
        getNextval();
        int sum = 0;
        for (int i = 0; i < p; i++) {
            int index = 0;
            int temp[size];
            for (int j = i; j < n&&i + (m - 1)*p < n; j += p) {
                temp[index++] = a[j];
            }
            sum += kmp(temp,index);
        }
        printf("Case #%d: %d\n", t, sum);
    }
    return 0;
}


 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值