Sequence I

8 篇文章 0 订阅
Mr. Frog has two sequences a1,a2,⋯,ana1,a2,⋯,an and b1,b2,⋯,bmb1,b2,⋯,bm and a number p. He wants to know the number of positions q such that sequence b1,b2,⋯,bmb1,b2,⋯,bm is exactly the sequence aq,aq+p,aq+2p,⋯,aq+(m−1)paq,aq+p,aq+2p,⋯,aq+(m−1)p where q+(m−1)p≤nq+(m−1)p≤n and q≥1q≥1.
Input
The first line contains only one integer T≤100T≤100, which indicates the number of test cases.

Each test case contains three lines.

The first line contains three space-separated integers 1≤n≤106,1≤m≤1061≤n≤106,1≤m≤106 and 1≤p≤1061≤p≤106.

The second line contains n integers a1,a2,⋯,an(1≤ai≤109)a1,a2,⋯,an(1≤ai≤109).

the third line contains m integers b1,b2,⋯,bm(1≤bi≤109)b1,b2,⋯,bm(1≤bi≤109).
Output
For each test case, output one line “Case #x: y”, where x is the case number (starting from 1) and y is the number of valid q’s.
Sample Input
2
6 3 1
1 2 3 1 2 3
1 2 3
6 3 2
1 3 2 2 3 1
1 2 3
Sample Output
Case #1: 2

Case #2: 1


直接暴力枚举。


#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int a[1000000];
int b[1000000];
int main()
{

    int n,m,i,j,k,t,p,l;
    scanf("%d",&t);
    k=1;
    while(t--)
    {
        int sum=0;
        scanf("%d %d %d",&n,&m,&p);
        for(i=0; i<n; i++)
        {
            scanf("%d",&a[i]);
        }
        for(i=0; i<m; i++)
        {
            scanf("%d",&b[i]);
        }
        for(i=0; i<n; i++)
        {
            for(j=0,l=i; j<m&&l<n; )
            {
                //printf("%d %d\n",a[l],b[j]);
                if(a[l]==b[j])
                {
                    l+=p;
                    j++;
                }
                if(a[l]!=b[j])
                    break;
            }
            if(j==m)
            {
                sum++;
            }
        }
        printf("Case #%d: ",k);
        k++;
        printf("%d\n",sum);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值