PAT甲级 A1032

PAT甲级 A1032

题目详情

1032 Sharing (25分)
To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, loading and being are stored as showed in Figure 1.

fig.jpg

You are supposed to find the starting position of the common suffix (e.g. the position of i in Figure 1).

Input Specification:
Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (≤10
​5
​​ ), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Data Next

whereAddress is the position of the node, Data is the letter contained by this node which is an English letter chosen from { a-z, A-Z }, and Next is the position of the next node.

Output Specification:
For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output -1 instead.

Sample Input 1:
11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010

Sample Output 1:
67890

Sample Input 2:
00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1

Sample Output 2:
-1

解题思路

这道题的思路很简单,开一个大于五位数的数组,每次读入数据都在数据地址下标内存入其下一次访问的地址。用A的开始地址先找一边所有的数据,并将其访问过的数据中的标志位设置为1,而后用B根据其起始地址进行访问,当访问到标志位为1时即为访问到了共同的地址,若未访问到则输出-1,需要注意的是,此处的测试点4存在问题,测试点4需要对于一些地址不到五位的数据进行补零输出(天坑!)
以下为AC代码部分

#include<iostream>
#include<string>
#include<vector>
#include<cmath>
#include<string>
#include<algorithm>
#include<iomanip>
using namespace std;
class node {
public:
	char no;
	int nextpos=-1;
	int visited = 0;
};
int main() {
	vector<node> lists(110000);
	int beginpos1; int beginpos2; int nos;
	cin >> beginpos1 >> beginpos2 >> nos;
	for (int i = 0; i < nos; i++) {
		int pos1; char temp; int npos1;
		cin >> pos1 >> temp >> npos1;
		lists[pos1].no = temp;
		lists[pos1].nextpos = npos1;
	}
	int t = beginpos1;
	while (true) {//标记A访问节点情况
		lists[t].visited = 1;
		t = lists[t].nextpos;
		if (t == -1) {
			break;
		}
	}
	int judge = 0; int pos = 0;
	while (true) {//B模仿A进行后续访问
		if (beginpos2 == -1) {
			break;
		}
		if (lists[beginpos2].visited == 1) {
			pos = beginpos2;
			judge = 1;
			break;
		}
		else {
			beginpos2 = lists[beginpos2].nextpos;
			if (beginpos2 == -1) {
				break;
			}
		}
	}
	if (judge == 1) {

		cout <<setfill('0')<<setw(5)<< pos << '\n';
	}
	else {
		cout << -1 << '\n';
	}
}
  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值