POJ-1861,Network,最小生成树水题,,注意题面输出有问题,不必理会~~

Network
Time Limit: 1000MS Memory Limit: 30000K
  微笑吐舌头偷笑大笑  吐舌头大笑偷笑偷笑  Special Judge

http://poj.org/problem?id=1861

Description

Andrew is working as system administrator and is planning to establish a new network in his company. There will be N hubs in the company, they can be connected to each other using cables. Since each worker of the company must have access to the whole network, each hub must be accessible by cables from any other hub (with possibly some intermediate hubs). 
Since cables of different types are available and shorter ones are cheaper, it is necessary to make such a plan of hub connection, that the maximum length of a single cable is minimal. There is another problem — not each hub can be connected to any other one because of compatibility problems and building geometry limitations. Of course, Andrew will provide you all necessary information about possible hub connections. 
You are to help Andrew to find the way to connect hubs so that all above conditions are satisfied. 

Input

The first line of the input contains two integer numbers: N - the number of hubs in the network (2 <= N <= 1000) and M - the number of possible hub connections (1 <= M <= 15000). All hubs are numbered from 1 to N. The following M lines contain information about possible connections - the numbers of two hubs, which can be connected and the cable length required to connect them. Length is a positive integer number that does not exceed 10 6. There will be no more than one way to connect two hubs. A hub cannot be connected to itself. There will always be at least one way to connect all hubs.

Output

Output first the maximum length of a single cable in your hub connection plan (the value you should minimize). Then output your plan: first output P - the number of cables used, then output P pairs of integer numbers - numbers of hubs connected by the corresponding cable. Separate numbers by spaces and/or line breaks.

Sample Input

4 6
1 2 1
1 3 1
1 4 2
2 3 1
3 4 1
2 4 1

Sample Output

1
4
1 2
1 3
2 3
3 4

Source

Northeastern Europe 2001, Northern Subregion

       我承认是无聊,在百度上找最小生成树的专题(链接),然后第一个就是这个题,,嘿嘿,虽然刚学,但对于这种不是很复杂的生成树的题,我还是有信心的,,只不过看样例看了一会,如果是最小生成树的话那么题面输出.........看了看讨论区证实了我的猜想大笑

 AC代码:

#include<cstdio>
#include<iostream>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
const int N=20000+10;
int n,m,f[1001];
struct node
{
    int u,v,w,vis;
} a[N];
int cmp(node a ,node b)
{
    return a.w<b.w;
}
int find(int x)
{
    return f[x]==-1?x:<span style="color:#ff0000;">x=find(f[x])</span>;//这里好容易就出错的;
}
void ks(int n)
{
    memset(f,-1,sizeof(f));
    sort(a,a+m,cmp);
    int ans=-1,cot=0;
    for(int i=0; i<m; i++)
    {
        int u=find(a[i].u);
        int v=find(a[i].v);
        if(u!=v)
        {
            f[u]=v;
            a[i].vis=1;//标记;
            cot++;
            ans=max(ans,a[i].w);//求出最长边;
        }
    }
    printf("%d\n%d\n",ans,cot);
    for(int i=0; i<m; i++)
        if(a[i].vis)
            printf("%d %d\n",a[i].u,a[i].v);
}
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        memset(a,0,sizeof(a));
        for(int i=0; i<m; i++)
            scanf("%d%d%d",&a[i].u,&a[i].v,&a[i].w);
        ks(n);
    }
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值