HDU5904 思路不错的dp....比我的蠢逼LCS强多了

Problem Description

Alex has two sequences a1,a2,…,an and b1,b2,…,bm. He wants find a longest common subsequence that consists of consecutive values in increasing order.

Input

There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:

The first line contains two integers n and m (1≤n,m≤100000) – the length of two sequences. The second line contains n integers: a1,a2,…,an (1≤ai≤106). The third line contains n integers: b1,b2,…,bm (1≤bi≤106).

There are at most 1000 test cases and the sum of n and m does not exceed 2×106.

Output

For each test case, output the length of longest common subsequence that consists of consecutive values in increasing order.

Sample Input

3
3 3
1 2 3
3 2 1
10 5
1 23 2 32 4 3 4 5 6 1
1 2 3 4 5
1 1
2
1

Sample Output

1
5
0

这题的关键点被我这个蠢逼给漏了…
那就是递增的差必须为1…
这样只要两个数列挨个扫一下就可以的。
然而一看见最长公共我就脑子发热写了个滚动的LCS
宛如一个智障….n+m=2*10^6讲道理mn对半分的话….
滚动数组省空间但是不省时间啊
10^12….gg

看了dalao的代码豁然开朗
不管有没有xjb转移就对了….
这样没有就是一转移…
简直完美…

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<memory.h>
using namespace std;
int n, m;
int dp1[200001], dp2[200001],a[100001],b[100001];
int main()
{
    int T;
    cin >> T;
    while (T--)
    {
        cin >> n >> m;
        memset(dp1, 0, sizeof(dp1));
        memset(dp2, 0, sizeof(dp2));
        for (int q = 0;q < n;q++)scanf("%d", &a[q]);
        for (int q = 0;q < m;q++)scanf("%d", &b[q]);
        for (int q = 0;q < n;q++)dp1[a[q]] = dp1[a[q] - 1] + 1;
        for (int q = 0;q < m;q++)dp2[b[q]] = dp2[b[q] - 1] + 1;
        int sum = 0;
        for (int q = 0;q < 200001;q++)sum = max(sum, min(dp1[q], dp2[q]));
        cout << sum << endl;
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值