PAT Advanced 1012. The Best Rank (25) (C语言实现)

我的PAT系列文章更新重心已移至Github,欢迎来看PAT题解的小伙伴请到Github Pages浏览最新内容。此处文章目前已更新至与Github Pages同步。欢迎star我的repo

题目

To evaluate the performance of our first year CS majored students, we consider
their grades of three courses only: C - C Programming Language, M -
Mathematics (Calculus or Linear Algrbra), and E - English. At the mean
time, we encourage students by emphasizing on their best ranks – that is,
among the four ranks with respect to the three courses and the average grade,
we print the best rank for each student.

For example, The grades of C, M, E and A - Average of 4 students are
given as the following:

StudentID  C  M  E  A
310101     98 85 88 90
310102     70 95 88 84
310103     82 87 94 88
310104     91 91 91 91

Then the best ranks for all the students are No.1 since the 1st one has done
the best in C Programming Language, while the 2nd one in Mathematics, the 3rd
one in English, and the last one in average.

Input Specification:

Each input file contains one test case. Each case starts with a line
containing 2 numbers N N N and M M M ( ≤ 2000 \le 2000 2000 ), which are the total number of
students, and the number of students who would check their ranks,
respectively. Then N N N lines follow, each contains a student ID which is a
string of 6 digits, followed by the three integer grades (in the range of [0,
100]) of that student in the order of C, M and E. Then there are M M M
lines, each containing a student ID.

Output Specification:

For each of the M M M students, print in one line the best rank for him/her, and
the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > > > C > > > M > > >
E. Hence if there are two or more ways for a student to obtain the same best
rank, output the one with the highest priority.

If a student is not on the grading list, simply output N/A.

Sample Input:

5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999

Sample Output:

1 C
1 M
1 E
1 A
3 A
N/A

思路

计算排名的方法:

很多人用的结构体排序,这样是比较耗时的(尤其是基数很大的时候)。

我的方法是在读取学生成绩的时候顺便记录0~100分各有多少人,然后根据得分人数计算排名。举个例子:

  • 如果100分有1人,99分有2人,98分有3人,97分有4人。

那么

  • 得100分的排名是1,得99分的排名是2(并列),98分的排名是4(并列),97分的排名是7(并列)。

规律是什么?如果学生获得的分数分别有a1>a2>a3>…>ai>…,那么

  • 分数a[i]的名次 = 分数a[i-1]的名次 + 分数a[i-1]的人数
  • 分数a[1]的名次 = 1

这其实是递归定义,如果定义一个不存在的高分a0(比如101分)人数=1(代码中一开始的初始化就是做这个),那么上面的关系就简化成了

  • 分数a[i]的名次 = a[0]~a[i-1]的人数总和,(i>0)

可以验证一下:97分的排名=98~101分人数总和=3+2+1+1=7

平均分计算方法:

仔细看题目中给的例子,平均分是四舍五入的,不过我试过在算平均分的时候直接3个数相加除以3,还是能AC。所以要不是题目没有设置这样的测试点,要不就是题目认为两种算法结果都正确。

代码

最新代码@github,欢迎交流

#include <stdio.h>

typedef struct Student{ int ID, score[4]; } Student;

int main()
{
    /* scores array stores the number of students of any score */
    int N, M, ID, scores[4][102] = {{0}};

    /* Setting a score of 101 is to make it easy to calculate rank */
    scores[0][101] = scores[1][101] = scores[2][101] = scores[3][101] = 1;
    Student students[2000];

    scanf("%d %d", &N, &M);
    for(int i = 0; i < N; i++)
    {   /* record all the scores for every student: A, C, M, E */
        Student *s = students + i;
        scanf("%d %d %d %d", &s->ID, &s->score[1], &s->score[2], &s->score[3]);
        s->score[0] = (s->score[1] + s->score[2] + s->score[3] + 1) / 3;
        for(int j = 0; j < 4; j++)                         /* +1 for rounding */
            scores[j][s->score[j]]++;       /* record how many got this score */
    }

    for(int i = 0; i < M; i++)
    {
        int max = 3, ranks[4] = {0}, stu;

        scanf("%d", &ID);
        for(stu = 0; stu < N && students[stu].ID != ID; stu++) ;      /* find */
        if(stu == N) { puts("N/A"); continue;}

        for(int j = 3; j >= 0; j--)
        {   /* calculate the rank: sum the counts from score + 1 to 101 */
            /* e.g. score 100 will have rank 1, since scores[101] is 1 */
            for(int score = 100; score >= students[stu].score[j]; score--)
                ranks[j] += scores[j][score + 1];
            if(ranks[j] <= ranks[max]) /* The best rank with highest priority */
                max = j;
        }
        printf("%d %c\n", ranks[max], "ACME"[max]);
    }
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值