1001. A+B Format

Calculate a + b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input

Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.

Output

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input
-1000000 9
Sample Output
-999,991

分析:这道题就是按照给定的格式输出2个数的和,由于a,b都是<=1000000的,所以可以直接进行判断,在编写中要注意0的情况


code:

#include <stdio.h>
#include <stdlib.h>

int main()
{
    long int a,b;               //定义变量a,b和sum
    scanf("%ld %ld",&a,&b);     //输入a,b
    long sum = a + b;                //将a,b之和赋值给sum
    if(sum<0){                  //判断是否为负数
        sum = -1*sum;         //变为正的
        printf("-");            //输出负号
    }
    if(sum>=1000000){            //当大于1000000时
        printf("%ld,%03ld,%03ld",sum/1000000,sum/1000%1000,sum%1000);
    }
    else if(sum>=1000){               //当大于1000时
        printf("%ld,%03ld",sum/1000,sum%1000);
    }
    else{                       //小于1000时
        printf("%ld",sum);
    }
    
    return 0;
}

============================================================================================================

今天又开始啦,做完数据结构的题后继续做做PAT的啦,继续努力啦。。。^_^

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值