动态规划 HDU-2577

How to Type

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6519    Accepted Submission(s): 2932

Problem Description
Pirates have finished developing the typing software. He called Cathy to test his typing software. She is good at thinking. After testing for several days, she finds that if she types a string by some ways, she will type the key at least. But she has a bad habit that if the caps lock is on, she must turn off it, after she finishes typing. Now she wants to know the smallest times of typing the key to finish typing a string.
 
Input
The first line is an integer t (t<=100), which is the number of test case in the input file. For each test case, there is only one string which consists of lowercase letter and upper case letter. The length of the string is at most 100.
 
Output
For each test case, you must output the smallest times of typing the key to finish typing this string.
 
Sample Input
  
  
3 Pirates HDUacm HDUACM
 
Sample Output
  
  
8 8 8
Hint
The string “Pirates”, can type this way, Shift, p, i, r, a, t, e, s, the answer is 8. The string “HDUacm”, can type this way, Caps lock, h, d, u, Caps lock, a, c, m, the answer is 8 The string "HDUACM", can type this way Caps lock h, d, u, a, c, m, Caps lock, the answer is 8
 
打字,大写可以选择开大写灯或者按shift,最后一定要把灯关闭。还有大写灯开着时按shift可以打小写。
因为涉及到大写灯开关时有多种情况,要用dp解决。数组可以设为dp[i][j],表示第i个字母时灯的状态(1或0)。

1、打大写并开灯:若前一个灯开,dp[i-1][1]+1;若没开,dp[i-1][0]+2.
2、打大写不开灯:若前一个灯开,dp[i-1][1]+2;若没开,dp[i-1][0]+2.
3、打小写并开灯:若前一个灯开,dp[i-1][1]+2;若没开,dp[i-1][0]+2.
4、打小写不开灯:若前一个灯开,dp[i-1][1]+2;若没开,dp[i-1][0]+1.

#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;
int dp[120][2];
char str[120];

bool Judge(char x)
{
    if(x >= 'A' && x <= 'Z') return true;
    else return false;
}
// dp[i][j], j表示大写灯开关
int main()
{
    int T;
    scanf("%d", &T);
    while(T--) {
        scanf("%s", str + 1);
        memset(dp, 0, sizeof(dp));
        dp[0][1] = 1; // 不能漏掉!!!
        int len = strlen(str + 1);
        for(int i = 1; i <= len; i++) {
            if(Judge(str[i])) {
                dp[i][1] = min(dp[i-1][1] + 1, dp[i-1][0] + 2);
                dp[i][0] = min(dp[i-1][1] + 2, dp[i-1][0] + 2);
            }
            else {
                dp[i][1] = min(dp[i-1][1] + 2, dp[i-1][0] + 2);
                dp[i][0] = min(dp[i-1][1] + 2, dp[i-1][0] + 1);
            }
        }
        printf("%d\n", min(dp[len][0], dp[len][1] + 1));
    }
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值