Cleaning Shifts POJ - 2376 (农场主找更少的牛完成工作+考虑工作时间开头与结尾)

Farmer John is assigning some of his N (1 <= N <= 25,000) cows to do some cleaning chores around the barn. He always wants to have one cow working on cleaning things up and has divided the day into T shifts (1 <= T <= 1,000,000), the first being shift 1 and the last being shift T.

Each cow is only available at some interval of times during the day for work on cleaning. Any cow that is selected for cleaning duty will work for the entirety of her interval.

Your job is to help Farmer John assign some cows to shifts so that (i) every shift has at least one cow assigned to it, and (ii) as few cows as possible are involved in cleaning. If it is not possible to assign a cow to each shift, print -1.
Input

  • Line 1: Two space-separated integers: N and T

  • Lines 2…N+1: Each line contains the start and end times of the interval during which a cow can work. A cow starts work at the start time and finishes after the end time.
    Output

  • Line 1: The minimum number of cows Farmer John needs to hire or -1 if it is not possible to assign a cow to each shift.
    Sample Input
    3 10
    1 7
    3 6
    6 10
    Sample Output
    2
    Hint
    This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

INPUT DETAILS:

There are 3 cows and 10 shifts. Cow #1 can work shifts 1…7, cow #2 can work shifts 3…6, and cow #3 can work shifts 6…10.

OUTPUT DETAILS:

By selecting cows #1 and #3, all shifts are covered. There is no way to cover all the shifts using fewer than 2 cows.

题意:

农场主想要找最少的牛帮他完成T时间的的清洁工作,但每一头牛的工作时间都是在固定的某一个区间,现需求完成1~T时间的牛的最少数量。

思路:

先对牛的工作时间进行排序。按开始时间从小到大排序,如果开始时间相同,就按结束时间从小到大。
时间刚开始必须是从1开始。如果排序后的第一头牛的开始时间不是1,那么就输出-1,每次遍历更新结束时间最大值,选择符合条件的结束时间最大的值,更新maxx值,当遍历到开始时间比maxx值大时,记录下标id,下次遍历从id开始,减少时间的浪费,如果最后的maxx值小于m,则输出-1。

代码:

#include<stdio.h>
#include<algorithm>
using namespace std;
struct node
{
    int s;
    int e;
} a[30010];
bool cmp(node x,node y)
{
    if(x.s==y.s)
        return x.e<y.e;
    return x.s<y.s;
}
int main()
{
    int n,m;
    scanf("%d %d",&n,&m);
    for(int i=0; i<n; i++)
        scanf("%d %d",&a[i].s,&a[i].e);
    sort(a,a+n,cmp);
    int id=0,k=0;
    int maxx=0,minn;
    if(a[0].s!=1)
        printf("-1\n");
    else
    {
        while(maxx<m)
        {
            minn=maxx+1;
            for(int i=id; i<n; i++)
            {
                if(a[i].s<=minn&&a[i].e>=minn)
                {
                    maxx=max(maxx,a[i].e);
                }
                else if(a[i].s>minn)
                {
                    id=i;
                    break;
                }
            }
            if(minn>maxx)
                break;
            else
                k++;
        }
        if(maxx<m)
            printf("-1\n");
        else
            printf("%d\n",k);
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值