Monthly Expense POJ - 3273( 最大值最小+月份分区间求开销限额最小值 )

Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤ moneyi ≤ 10,000) that he will need to spend each day over the next N (1 ≤ N ≤ 100,000) days.

FJ wants to create a budget for a sequential set of exactly M (1 ≤ M ≤ N) fiscal periods called “fajomonths”. Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.

FJ’s goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.

Input

Line 1: Two space-separated integers: N and M
Lines 2…N+1: Line i+1 contains the number of dollars Farmer John spends on the ith day

Output

Line 1: The smallest possible monthly limit Farmer John can afford to live with.

Sample Input

7 5
100
400
300
100
500
101
400

Sample Output

500

Hint

If Farmer John schedules the months so that the first two days are a month, the third and fourth are a month, and the last three are their own months, he spends at most $500 in any month. Any other method of scheduling gives a larger minimum monthly limit.

题意:

给出N天的Farmer John 的花销,计算将这N天分成M段区间,M段区间中一定有一个最大值,我们要尽量最小化这个最大值。

思路:

二分计算,先计算出给出的N天开销中的最大值和N天开销的总和,在最大值与总和之间二分求值,每次记录分段的数量以及每一段的总和,当分段的数量<=m段时,说明这个最大值可能还是有一点大,就缩小区间,让右边R=mid,反之,则让左边L=mid+1,最后我们需要求的结果即为R值。

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int a[100010];
int main()
{
    int n,m;
    scanf("%d %d",&n,&m);
    int l=-1,r=0;
    for(int i=0; i<n; i++)
    {
        scanf("%d",&a[i]);
        if(l<a[i])
            l=a[i];//最大的
        r+=a[i];//总和
    }
    while(l<r)
    {
        int mid=(l+r)/2;
        int num=0;//记录分段的数量
        int sum=0;//记录每一段的和
        //定义mid为所求最小值的一个初值吧
        //实现二分思路
        for(int i=0; i<n; i++)
        {
            if(sum+a[i]>mid)
            {
                num++;
                sum=a[i];
            }
            else
                sum+=a[i];
        }
        num++;
        if(num<=m)
            r=mid;
        else
            l=mid+1;
    }
    printf("%d\n",r);
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值