POJ1611 The Suspects

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. 
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP). 
Once a member in a group is a suspect, all members in the group are suspects. 
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
Input
The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space. 
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output
For each case, output the number of suspects in one line.
Sample Input
100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0
Sample Output
4
1
1

Status Accepted
Time 32ms
Memory 472kB
Length 584
Lang C++
Submitted
Shared
RemoteRunId 16894844
题目大意:

首先输入一个学生的数量+小组数量 //两者均未0时,输入结束。

0所在小组的组员,全部感染。如果这些被感染的组员还在其他组中,那么这个其他组中的所有组员也被感染了。、

输出这个被感染的人员数量。





#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
using namespace std;
int a[30007];//存  父 
int s[30007];//存  秩  
int n,m,k;
int find(int i)
{
	while(i!=a[i])
		i=a[i];
	return i;//找到根 
}
int main()
{
	int x1,x2;
	int i,j;
	while(scanf("%d%d",&n,&m)!=EOF&&(n||m))
	{
		for(i=0;i<n;i++)
		{
			a[i]=i;
			s[i]=1;
		}
		for(i=0;i<m;i++)
		{
			scanf("%d%d",&k,&x1);
			for(j=1;j<k;j++)
			{
				scanf("%d",&x2);
				x1=find(x1);
				x2=find(x2);
				if(x1!=x2)
				{
					s[x1]+=s[x2];
					a[x2]=x1;
				 } 
			}
		}
		cout<<s[find(0)]<<endl;
	}
	return 0;
 } 



















































  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值