Spell checker(字符串练习)

 

Description

You, as a member of a development team for a new spell checking program, are to write a module that will check the correctness of given words using a known dictionary of all correct words in all their forms.
If the word is absent in the dictionary then it can be replaced by correct words (from the dictionary) that can be obtained by one of the following operations:
?deleting of one letter from the word;
?replacing of one letter in the word with an arbitrary letter;
?inserting of one arbitrary letter into the word.
Your task is to write the program that will find all possible replacements from the dictionary for every given word.

Input

The first part of the input file contains all words from the dictionary. Each word occupies its own line. This part is finished by the single character '#' on a separate line. All words are different. There will be at most 10000 words in the dictionary.
The next part of the file contains all words that are to be checked. Each word occupies its own line. This part is also finished by the single character '#' on a separate line. There will be at most 50 words that are to be checked.
All words in the input file (words from the dictionary and words to be checked) consist only of small alphabetic characters and each one contains 15 characters at most.

Output

Write to the output file exactly one line for every checked word in the order of their appearance in the second part of the input file. If the word is correct (i.e. it exists in the dictionary) write the message: " is correct". If the word is not correct then write this word first, then write the character ':' (colon), and after a single space write all its possible replacements, separated by spaces. The replacements should be written in the order of their appearance in the dictionary (in the first part of the input file). If there are no replacements for this word then the line feed should immediately follow the colon.

Sample Input

i
is
has
have
be
my
more
contest
me
too
if
award
#
me
aware
m
contest
hav
oo
or
i
fi
mre
#

Sample Output

me is correct
aware: award
m: i my me
contest is correct
hav: has have
oo: too
or:
i is correct
fi: i
mre: more me

题目大意:第一个#号前是给出的现有的词汇,第二个#号前是需要查找的单词。查找规则:1.改动一个字母。2.去掉一个字母。3.增加一个字母。满足任一条件能在词库中找出就输出。

 

 

思路:3种规则是2种,能直接找到与需要变换,需要变换分直接字母变化与增减。相同长度情况需要判断是否为原单词与需改变一个字母的情况,不同长度可以理解为长的枚举去掉一个字母后与短的进行匹配。此处去掉字母代码略繁,使用按顺序统计匹配字母个数,再与短字符串长度比较判断。

 

代码如下:

#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<map>
#include<set>
#include<string.h>
#include<string>
using namespace std;
string s[10005],s1;
int main()
{
	ios::sync_with_stdio(false);
	int i,j,k,h=0,h1=0;
	while(cin>>s[h]&&s[h]!="#") {h++;}
	while(cin>>s1&&s1!="#")
	{
        int fag=0;    
        for(int j=0;j<h;j++)
        {
            if(s1==s[j]) 
            {
                cout<<s1<<" is correct"<<endl;
                fag=1;
                break;
            }
        }//原单词直接找出
        if(fag==1) 
        continue;
        int len=s1.size();
        cout<<s1<<":";
        for(int j=0;j<h;j++)
        {
            int l=s[j].size();
            if(l==len||l==len+1||l==len-1)
            {  
                int ans=0;
                if(len>l)
                {   
                    for(int m=0,d=0;m<len;m++)
                    {
                        if(s1[m]==s[j][d])
                        {
                            ans++;
                            d++;
                        }
                    }
                }
                else if(len<l)
                {
                    for(int m=0,d=0;m<l;m++)
                    {
                        if(s[j][m]==s1[d])
                        {
                            ans++;
                            d++;
                        }
                    }
                }//长度不同时统计可匹配的字母数ans
                else if(len==l)
                {
                    for(int m=0,d=0;m<l;m++,d++)
                        if(s[j][m]==s1[d]) 
                           ans++;
                }
                if(len>=l&&ans==len-1||ans==len)  
                    cout<<" "<<s[j];    //将已匹配的字母数与短字符串长度进行比较,输出
            }
        }
        cout<<endl;
    }
	return 0;
}

 

 

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Code Spell Checker是一个用于检查代码中拼写错误的插件。当它检测到不是标准的英文单词时,会报错。为了避免这种情况影响代码编写体验,可以对该插件进行配置,让它在遇到特定词汇时不报错。在VSCode中进行配置的步骤如下: 1. 打开设置(Settings)。 2. 打开setting.json文件。 3. 在setting.json文件中添加以下代码:"cSpell.userWords": \["axios", 更多词汇...\]。 另外,还可以通过修改Code Spell Checker的settings.json文件来添加错误的单词。具体操作如下: 1. 打开设置(Settings)。 2. 打开用户(User)。 3. 打开扩展(Extensions)。 4. 找到安装的Code Spell Checker并打开settings.json。 5. 在其中找到图6的内容。 6. 修改其中的内容,添加错误的单词。例如,可以添加bindblur单词。 如果是在工作区添加单词到词典中,可以在VSCode的项目文件夹中的.vscode文件夹下的settings.json文件中进行修改。以上是解决Code Spell Checker报错的一些方案。 #### 引用[.reference_title] - *1* [code spell checker插件规避掉一些特定词汇报错“xxx“: Unknown word.cSpell](https://blog.csdn.net/angrynouse/article/details/125846273)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v91^control_2,239^v3^insert_chatgpt"}} ] [.reference_item] - *2* *3* [VSCode中插件Code Spell Checker](https://blog.csdn.net/qq_42078081/article/details/115014474)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v91^control_2,239^v3^insert_chatgpt"}} ] [.reference_item] [ .reference_list ]

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值