Bomb

题目描述:

The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence “49”, the power of the blast would add one point.
Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?

输入:

The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.

The input terminates by end of file marker.

输出:

For each test case, output an integer indicating the final points of the power.

样例输入:

3
1
50
500

样例输出:

0
1
15

数位dp,堪称一道模板题,过程可能有点迷,要好好想想
上代码:

#include<iostream>
#include<stdio.h>
#include<algorithm>
#include<string.h>
#include<math.h>
using namespace std;
long long dp[20][15];
void init()
{
	memset(dp,0,sizeof(dp));
	dp[0][0]=1;
	for(int i=1;i<=20;i++)
	{
		for(int j=0;j<=9;j++)
		{
			for(int k=0;k<=9;k++)
			{
				if(!(j==4&&k==9))
				dp[i][j]+=dp[i-1][k];
			}
		}
	}
}
long long solve(long long n)
{
	long long ans=0;
	long long len=0;
	int digit[20];
	memset(digit,0,sizeof(digit));
	while(n)
	{
		digit[++len]=n%10;
		n/=10;
	}
	for(int i=len;i>=1;i--)
	{
		for(int j=0;j<digit[i];j++)
		{
			if(!(digit[i+1]==4&&j==9))
			ans+=dp[i][j];
		}
		if(digit[i+1]==4&&digit[i]==9)
		{
			break;
		}
	}
	return ans;
}
int main()
{
	init();
	int ttt;
	scanf("%d",&ttt);
	while(ttt--)
	{
		long long n;
		scanf("%lld",&n);
		printf("%lld\n",n+1-solve(n+1));
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值