HDU 5914 Triangle【斐波那契数列】

8 篇文章 0 订阅

Triangle

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 178    Accepted Submission(s): 127


Problem Description
Mr. Frog has n sticks, whose lengths are 1,2, 3 n respectively. Wallice is a bad man, so he does not want Mr. Frog to form a triangle with three of the sticks here. He decides to steal some sticks! Output the minimal number of sticks he should steal so that Mr. Frog cannot form a triangle with
any three of the remaining sticks.
 

Input
The first line contains only one integer T ( T20 ), which indicates the number of test cases. 

For each test case, there is only one line describing the given integer n ( 1n20 ).
 

Output
For each test case, output one line “Case #x: y”, where x is the case number (starting from 1), y is the minimal number of sticks Wallice should steal.
 

Sample Input
  
  
3 4 5 6
 

Sample Output
  
  
Case #1: 1 Case #2: 1 Case #3: 2
 

Source

题意:有1~n n个数,问最少拿走多少个数能使剩下的数不能构成三角形。

规律:

     首先考虑一下,除开123不谈,任意三个相邻的数是肯定可以组成三角形的;并且如果有两个数很近的时候,也肯定可以和另一个数组成三角形(两边之差小于第三边);因此我们考虑有一定间隔的情况,即对于剩下的边总有a[i]+a[i+1]=a[i+2],因此想到斐波那契数列,接下来我们证明它的充要性;

充分性:a[i]+a[i+1]=a[i+2],那个对于每一个比a[i+2]更大的数一定小于a[i]+a[i+1],因此可证;

必要性:如果有任意一个比a[i+1]大一点的数,那么要么对于当前的a[i+2]满足两边之和大于第三边,就可以构成三角形;如果是小一点,那么对于前面的一组数又可以组成三角形,因此可证;

因此斐波那契数列可行~


那么就需符合:1 2 3 5 8 13......

#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<climits>
#include<string>
#include<queue>
#include<stack>
#include<set>
#include<map>
#include<algorithm>
using namespace std;
#define rep(i,j,k)for(i=j;i<k;i++)
#define per(i,j,k)for(i=j;i>k;i--)
#define MS(x,y)memset(x,y,sizeof(x))
#define max(a,b) a>b?a:b
#define min(a,b) a<b?a:b
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
typedef long long LL;
const int INF=0x7ffffff;

int num[22]={0,0,0,0,1,1,2,3,3,4,5,6,7,7,8,9,10,11,12,13,14};

int main()
{
  int T;
  int Case=1;
  int n;
  scanf("%d",&T);
  while(T--){
    scanf("%d",&n);
    printf("Case #%d: %d\n",Case++,num[n]);
  }
  return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值