Let the Balloon Rise

 

Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you. 

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters. 

A test case with N = 0 terminates the input and this test case is not to be processed. 

Output

For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case. 

Sample Input

5
green
red
blue
red
red
3
pink
orange
pink
0

Sample Output

red
pink

题意:
求每组字符串出现次数最多的一个字符串
思路:
将每个字符串出现次数存在一个数组中,然后求出现次数最多的字符串
代码:
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int s[1100],t;
char str[1100][1100];
int main()
{
    while(~scanf("%d",&t)&&t)
    {
        getchar();
        int num=0,n=0;
        for(int i=0;i<t;i++)
            gets(str[i]);//存字符串
            for(int i=0;i<t;i++)
          {     num=0;
                for(int j=0;j<t;j++)
                {
                    if( strcmp(str[i],str[j])==0)//判断两字符串是否一样
                        num++;//一样则出现次数加一
                }
                s[i]=num;//将每种字符串出现次数存在数组中
            }
            for(int i=0;i<t;i++)
            {   n=0;
                for(int j=0;j<t;j++)

                    if(s[i]>=s[j])
                        n++;
                    if(n==t)//找出出现次数最多的字符串输出
                    {
                        printf("%s\n",str[i]);break;
                    }

            }
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值