Minimum Transport Cost HDU - 1385

These are N cities in Spring country. Between each pair of cities there may be one transportation track or none. Now there is some cargo that should be delivered from one city to another. The transportation fee consists of two parts: 
The cost of the transportation on the path between these cities, and 

a certain tax which will be charged whenever any cargo passing through one city, except for the source and the destination cities. 

You must write a program to find the route which has the minimum cost. 

Input

First is N, number of cities. N = 0 indicates the end of input. 

The data of path cost, city tax, source and destination cities are given in the input, which is of the form: 

a11 a12 ... a1N 
a21 a22 ... a2N 
............... 
aN1 aN2 ... aNN 
b1 b2 ... bN 

c d 
e f 
... 
g h 

where aij is the transport cost from city i to city j, aij = -1 indicates there is no direct path between city i and city j. bi represents the tax of passing through city i. And the cargo is to be delivered from city c to city d, city e to city f, ..., and g = h = -1. You must output the sequence of cities passed by and the total cost which is of the form: 

Output

From c to d : 
Path: c-->c1-->......-->ck-->d 
Total cost : ...... 
...... 

From e to f : 
Path: e-->e1-->..........-->ek-->f 
Total cost : ...... 

Note: if there are more minimal paths, output the lexically smallest one. Print a blank line after each test case. 
 

Sample Input

5
0 3 22 -1 4
3 0 5 -1 -1
22 5 0 9 20
-1 -1 9 0 4
4 -1 20 4 0
5 17 8 3 1
1 3
3 5
2 4
-1 -1
0

Sample Output

From 1 to 3 :
Path: 1-->5-->4-->3
Total cost : 21

From 3 to 5 :
Path: 3-->4-->5
Total cost : 16

From 2 to 4 :
Path: 2-->1-->5-->4
Total cost : 17

题意:
n个城市,给出这些城市之间的邻接矩阵,矩阵中-1代表那两个城市无道路相连,其他值代表路径长度。
如果一辆汽车现在要从a城到b城,花费为路径长度之和,再加上除起点与终点外所有城市的过路费之和。
求最小花费,如果有多条路经符合,则输出字典序最小的路径。
思路:
最短路问题,采用floyd算法
更新的s[i][j]代表过路费,输出路径,初始化路径path[i][j]=j、当path[i][j]路径经过点k松弛之后,path[i][j]=path[i][k]。
字典序输出:当s[i][j]==s[i][k]+s[k][j]+val[k]的时候,当path[i][j]>path[i][k]的时候,更新path[i][j]为path[i][k]、
保证了过路费最小且相等的时候,使得字典序最小。

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int s[1500][1500],val[1500],path[1500][1500];
int n;
void floyd()
{
    for(int i=1; i<=n; i++)
    {
        for(int j=1; j<=n; j++)
        {
            for(int k=1; k<=n; k++)
            {
                if(s[j][k]>s[j][i]+s[i][k]+val[i])
                {
                    s[j][k]=s[j][i]+s[i][k]+val[i];
                    path[j][k]=path[j][i];
                }
                else if(s[j][k]==s[j][i]+s[i][k]+val[i]&&path[j][k]>path[j][i])
                {
                    path[j][k]=path[j][i];
                }
            }
        }
    }
}
int main()
{
    while(~scanf("%d",&n)&&n)
    {
        int st,en;
        for(int i=1; i<=n; i++)
        {
            for(int j=1; j<=n; j++)
            {
                path[i][j]=j;
                scanf("%d",&s[i][j]);
                if(s[i][j]==-1)
                    s[i][j]=0x3f3f3f3f;
            }
        }
        for(int i=1; i<=n; i++)
            scanf("%d",&val[i]);
        floyd();
        while(scanf("%d%d",&st,&en))
        {
            if(st==-1&&en==-1)
                break;
            printf("From %d to %d :\n",st,en);
            printf("Path: ");
            int t=st;
            printf("%d",t);
            while(t!=en)
            {
                printf("-->%d",path[t][en]);
                t=path[t][en];
            }
            printf("\nTotal cost : %d\n",s[st][en]);
            printf("\n");
        }
    }
}
 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值