PAT 1095 甲级 Cars on Campus (30分)

Zhejiang University has 8 campuses and a lot of gates. From each gate we can collect the in/out times and the plate numbers of the cars crossing the gate. Now with all the information available, you are supposed to tell, at any specific time point, the number of cars parking on campus, and at the end of the day find the cars that have parked for the longest time period.
Input Specification:

Each input file contains one test case. Each case starts with two positive integers N (≤10​4​​), the number of records, and K (≤8×10​4​​) the number of queries. Then N lines follow, each gives a record in the format:

plate_number hh:mm:ss status

where plate_number is a string of 7 English capital letters or 1-digit numbers; hh:mm:ss represents the time point in a day by hour:minute:second, with the earliest time being 00:00:00 and the latest 23:59:59; and status is either in or out.

Note that all times will be within a single day. Each in record is paired with the chronologically next record for the same car provided it is an out record. Any in records that are not paired with an out record are ignored, as are out records not paired with an in record. It is guaranteed that at least one car is well paired in the input, and no car is both in and out at the same moment. Times are recorded using a 24-hour clock.

Then K lines of queries follow, each gives a time point in the format hh:mm:ss. Note: the queries are given in ascending order of the times.
Output Specification:

For each query, output in a line the total number of cars parking on campus. The last line of output is supposed to give the plate number of the car that has parked for the longest time period, and the corresponding time length. If such a car is not unique, then output all of their plate numbers in a line in alphabetical order, separated by a space.
Sample Input:

16 7
JH007BD 18:00:01 in
ZD00001 11:30:08 out
DB8888A 13:00:00 out
ZA3Q625 23:59:50 out
ZA133CH 10:23:00 in
ZD00001 04:09:59 in
JH007BD 05:09:59 in
ZA3Q625 11:42:01 out
JH007BD 05:10:33 in
ZA3Q625 06:30:50 in
JH007BD 12:23:42 out
ZA3Q625 23:55:00 in
JH007BD 12:24:23 out
ZA133CH 17:11:22 out
JH007BD 18:07:01 out
DB8888A 06:30:50 in
05:10:00
06:30:50
11:00:00
12:23:42
14:00:00
18:00:00
23:59:00

Sample Output:

1
4
5
2
1
0
1
JH007BD ZD00001 07:20:09

给出混杂的车辆进出时间,给出查询时间(问的是当前时刻的停车数)
PS:关于时分秒的时间格式,可以用秒做最小单位,统一处理。
定义结构,将车辆信息按车牌号排序,然后在循环找出符合逻辑的in/out记录。保存在结构体属性中。在vector中保存。
然后与查询的时间点进行比较。符合条件的话,in加1,out减1.。每趟循环输出一个计数。
然后将停车时长根据in/out时间计算出,取MAX,并记录车牌号。
结果输出。

#include<iostream>
#include<string>
#include<vector>
#include<algorithm>

using namespace std;

struct record {
	string plate_number;
	int hh,mm,ss;
	string status;
	bool operator<(record r) {
		if(plate_number != r.plate_number) {
			return plate_number < r.plate_number;
		} else if(hh != r.hh) {
			return hh < r.hh;
		} else if(mm != r.mm) {
			return mm < r.mm;
		} else {
			return ss <= r.ss;
		}
	}
};

struct pairRecord {
	string plate_number;
	int inhh,inmm,inss;
	int outhh,outmm,outss;
	int calculatetime() {
		return (outhh - inhh)*60*60 + (outmm - inmm)*60 + (outss - inss);
	}

};

struct pairRecord2 {
	string plate_number;
	int totaltime;
	pairRecord2():totaltime(0) {	}
};

bool cmp(record r1,record r2){
	if(r1.hh != r2.hh){
		return r1.hh < r2.hh;
	} else if(r1.mm != r2.mm){
		return r1.mm < r2.mm;
	}else{
		return r1.ss < r2.ss;
	}
}

int calculatetime(int qh,int qm,int qs){
	return qh*60*60 + qm*60 + qs;
}

int main() {
	int N,K;
	cin>>N>>K;
	record r;
	vector<record> v,vv;
	for(int i = 0; i < N; i++) {
		cin>>r.plate_number;
		scanf("%d:%d:%d",&r.hh,&r.mm,&r.ss);
		cin>>r.status;
		v.push_back(r);
	}
	sort(v.begin(),v.end());
	pairRecord pr;
	vector<pairRecord> vp;

	for(int i = 0; i < v.size() - 1; i++) {
		if(v[i].plate_number == v[i + 1].plate_number && v[i].status == "in" && v[i + 1].status == "out") {
			pr.plate_number = v[i].plate_number;
			pr.inhh = v[i].hh;
			pr.inmm = v[i].mm;
			pr.inss = v[i].ss;
			pr.outhh = v[i + 1].hh;
			pr.outmm = v[i + 1].mm;
			pr.outss = v[i + 1].ss;
			vp.push_back(pr);//目标车辆 
			vv.push_back(v[i]);
			vv.push_back(v[i + 1]);
		}
	}
	
	vector<pairRecord2> vp2;
	pairRecord2 pr2;
	string oldplate_number;
	oldplate_number = vp[0].plate_number;
	for(int i = 0 ; i < vp.size();i++){
		if(!i || vp[i].plate_number == oldplate_number){
			pr2.totaltime += vp[i].calculatetime();
			if(i == vp.size() - 1){
				pr2.plate_number = vp[i].plate_number;
				vp2.push_back(pr2);
			}
		}else {
			pr2.plate_number = vp[i - 1].plate_number;
			vp2.push_back(pr2);
			pr2.totaltime = 0;
			oldplate_number = vp[i].plate_number;
			pr2.totaltime += vp[i].calculatetime();
			if(i == vp.size() - 1){
				pr2.plate_number = vp[i].plate_number;
				vp2.push_back(pr2);
			}
		}
	}
	
	sort(vv.begin(),vv.end(),cmp);
	int time;
	int j = 0;
	int querytime = 0,qh,qs,qm,count = 0;
	for(int i = 0; i < K;i++){
		scanf("%d:%d:%d",&qh,&qm,&qs);
		querytime = calculatetime(qh,qm,qs);
		while(j < vv.size()){
			time = calculatetime(vv[j].hh,vv[j].mm,vv[j].ss);
			if(time <= querytime){
				if(vv[j].status == "in"){
					count++; 
				}else{
					count--;
				}
				j++;
			}else
				break;
		}
		cout<<count<<endl;
	}

	int max = -1;
	for(int i = 0 ;i < vp2.size();i++){
		if(max < vp2[i].totaltime){
			max = vp2[i].totaltime;
		}
	}
	vector<string> vs;
	for(int i = 0;i < vp2.size();i++){
		if(max == vp2[i].totaltime){
			vs.push_back(vp2[i].plate_number);
		}
	}
	sort(vs.begin(),vs.end());
	for(int i = 0;i < vs.size();i++){
		cout<<vs[i]<<" ";
		if(i == vs.size() - 1){
			printf("%02d:%02d:%02d",(max/3600)%60,(max/60)%60,max%60);
		}
	}
 
	return 0;
}

前辈传送门…

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值