POJ2151Check the difficulty of problems【概率dp求概率】

 

Check the difficulty of problems

Time Limit: 2000MS

 

Memory Limit: 65536K

Total Submissions: 5863

 

Accepted: 2556

Description

Organizing a programming contest is not an easy job. To avoid making the problems too difficult, the organizer usually expect the contest result satisfy the following two terms: 
1. All of the teams solve at least one problem. 
2. The champion (One of those teams that solve the most problems) solves at least a certain number of problems. 

Now the organizer has studied out the contest problems, and through the result of preliminary contest, the organizer can estimate the probability that a certain team can successfully solve a certain problem. 

Given the number of contest problems M, the number of teams T, and the number of problems N that the organizer expect the champion solve at least. We also assume that team i solves problem j with the probability Pij (1 <= i <= T, 1<= j <= M). Well, can you calculate the probability that all of the teams solve at least one problem, and at the same time the champion team solves at least N problems? 

Input

The input consists of several test cases. The first line of each test case contains three integers M (0 < M <= 30), T (1 < T <= 1000) and N (0 < N <= M). Each of the following T lines contains M floating-point numbers in the range of [0,1]. In these T lines, the j-th number in the i-th line is just Pij. A test case of M = T = N = 0 indicates the end of input, and should not be processed.

Output

For each test case, please output the answer in a separate line. The result should be rounded to three digits after the decimal point.

Sample Input

2 2 2

0.9 0.9

1 0.9

0 0 0

Sample Output

0.972


 

题意:给出每个队做出每道题的概率求T个队每个队都做出至少一道题且冠军队做出N道题以上的概率

#include<cstdio>
#include<cstdlib>
#include<cstring>
using namespace std;
double pr[1010][35][35];// 
double dp[1010][35];
double p[1010][35];
int main()
{
	int M,T,N,i,j,k;
	double p1,pN;
	while(scanf("%d%d%d",&M,&T,&N),M||T||N){
		memset(dp,0,sizeof(dp));
		for(i=1;i<=T;++i){
			for(j=1;j<=M;++j){
				scanf("%lf",&p[i][j]);
			}
		}
		memset(pr,0,sizeof(pr));
		memset(dp,0,sizeof(dp));
		p1=pN=1.0;
		for(i=1;i<=T;++i){
			pr[i][0][0]=1;
			for(j=1;j<=M;++j){
				pr[i][j][0]=pr[i][j-1][0]*(1.0-p[i][j]);
			}
			for(j=1;j<=M;++j){
				for(k=1;k<=M;++k){
					pr[i][j][k]=pr[i][j-1][k-1]*p[i][j]+pr[i][j-1][k]*(1-p[i][j]);//前j道题中做出k道题的概率 
				}
			}
			dp[i][0]=pr[i][M][0];
			for(j=1;j<=M;++j){
				dp[i][j]=dp[i][j-1]+pr[i][M][j];//做出j道题的概率 
			}
			p1=p1*(dp[i][M]-dp[i][0]);//解决题数在1~M之间的概率 
			pN=pN*(dp[i][N-1]-dp[i][0]);//解决题数在1~N-1之间的概率 即没有队做出N道题以上的概率 
		}
		printf("%.3lf\n",p1-pN);
	}
	return 0;
}


 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值