hdoj1140War on Weather



War on Weather

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 438    Accepted Submission(s): 239


Problem Description
After an unprovoked hurricane attack on the south shore, Glorious Warrior has declared war on weather. The first salvo in this campaign will be a coordinated pre-emptive attack on as many tropical depressions as possible. GW reckons that the attack will neutralize the tropical depressions before they become storms, and dissuade others from forming. 
GW has at his disposal k space-to-earth killer satellites at various locations in space. m tropical depressions are known to exist at various locations on the earth's surface. Each satellite can attack any number of targets on the earth provided there is line of sight between the satellite and each target. How many different targets can be hit? 
 

Input
The input consists of several test cases. Each case begins with a line containing integers 0 < k, m &le 100 as defined above. k lines follow, each giving x,y,z - the location in space of a satellite at the scheduled time of attack. m lines then follow, each giving x,y,z - the location of a target tropical depression. Assume the earth is a sphere centred at (0,0,0) with circumference 40,000 km. All targets will be on the surface of the earth (within 10-9 km) and all satellites will be at least 50 km above the surface. A line containing 0 0 follows the last test case. 
 

Output
For each test case, output a line giving the total number of targets that can be hit. If a particular target falls within 10-8 km of the boundary between being within line-of-sight and not, it may be counted either way. (That is, you need not consider rounding error so long as it does not exceed 10-8 km.) 
 

Sample Input
      
      
3 2 -10.82404031 -1594.10929753 -6239.77925152 692.58497298 -5291.64700245 4116.92402298 3006.49210582 2844.61925179 5274.03201053 2151.03635167 2255.29684503 5551.13972186 -1000.08700886 -4770.25497971 4095.48127333 3 4 0 0 6466.197723676 0 6466.197723676 0 6466.197723676 0 0 6366.197723676 0 0 6365.197723676 112.833485488 0 0 0 6366.197723676 0 -6366.197723676 0 0 0
 

Sample Output
      
      
2 3
 


题意:在地球表面有些点地球外有一些卫星问这些卫星能打到多少点;能打到即该点正对卫星该点与卫星的连线和地球不相交可以相切

解题思路:求出地球上与卫星的切线长如果卫星与到某点距离大于切线长不在攻击范围

#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<cmath>
#define PI acos(-1.0)
#define R (20000.0/PI)
#define eps 11e-9
using namespace std;
struct point{
	double x,y,z;
}sate[110],target[110];
int sgn(double n){
	if(fabs(n)<eps)return 0;
	else if(n<0)return -1;
	return 1;
}
int main()
{
	int n,m,i,j;
	while(scanf("%d%d",&n,&m),n||m){
		for(i=0;i<n;++i){
			scanf("%lf%lf%lf",&sate[i].x,&sate[i].y,&sate[i].z);
		}
		for(i=0;i<m;++i){
			scanf("%lf%lf%lf",&target[i].x,&target[i].y,&target[i].z);
		}
		int ans=0;
		for(i=0;i<m;++i){
			for(j=0;j<n;++j){
				double  d=sqrt(sate[j].x*sate[j].x+sate[j].y*sate[j].y+sate[j].z*sate[j].z-R*R);
				double dst=sqrt((sate[j].x-target[i].x)*(sate[j].x-target[i].x)+(sate[j].y-target[i].y)*(sate[j].y-target[i].y)+(sate[j].z-target[i].z)*(sate[j].z-target[i].z));	
				if(sgn(dst-d)<=0)break;
			}
			if(j<n)ans++;
		}
		printf("%d\n",ans);
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值