poj2553The Bottom of a Graph【scc+缩点】

Language:
The Bottom of a Graph
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 9679 Accepted: 4025

Description

We will use the following (standard) definitions from graph theory. Let  V be a nonempty and finite set, its elements being called vertices (or nodes). Let  E be a subset of the Cartesian product  V×V, its elements being called edges. Then  G=(V,E) is called a directed graph. 
Let  n be a positive integer, and let  p=(e1,...,en) be a sequence of length  n of edges  ei∈E such that  ei=(vi,vi+1) for a sequence of vertices  (v1,...,vn+1). Then  p is called a path from vertex  v1 to vertex  vn+1 in  G and we say that  vn+1 is reachable from  v1, writing  (v1→vn+1)
Here are some new definitions. A node  v in a graph  G=(V,E) is called a sink, if for every node  w in  G that is reachable from  vv is also reachable from  w. The bottom of a graph is the subset of all nodes that are sinks, i.e.,  bottom(G)={v∈V|∀w∈V:(v→w)⇒(w→v)}. You have to calculate the bottom of certain graphs.

Input

The input contains several test cases, each of which corresponds to a directed graph  G. Each test case starts with an integer number  v, denoting the number of vertices of  G=(V,E), where the vertices will be identified by the integer numbers in the set  V={1,...,v}. You may assume that  1<=v<=5000. That is followed by a non-negative integer  e and, thereafter,  e pairs of vertex identifiers  v1,w1,...,ve,we with the meaning that  (vi,wi)∈E. There are no edges other than specified by these pairs. The last test case is followed by a zero.

Output

For each test case output the bottom of the specified graph on a single line. To this end, print the numbers of all nodes that are sinks in sorted order separated by a single space character. If the bottom is empty, print an empty line.

Sample Input

3 3
1 3 2 3 3 1
2 1
1 2
0

Sample Output

1 3
2

Source

题意:如果一个点能到达一个点反过来这个点也能返回来则称他们为sink点输出sink中的点当一个点不能到达任何点时也要输出;

#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<stack>
#include<vector>
#include<set>
#define inf 0x3f3f3f3f
using namespace std;
const int maxn=1001010;
int dfs_clock,scc_cnt;
int head[maxn];
bool instack[maxn];
int low[maxn],dfn[maxn];
int sccno[maxn];
int in[maxn];
int out[maxn];
stack<int>S;
vector<int>scc[maxn];
vector<int>G[maxn];
set<int>s;
struct Node{
	int from,to,next;
}A[maxn];
int MIN(int a,int b){
	return a<b?a:b;
}
void init(){
	dfs_clock=scc_cnt=0;
	memset(head,-1,sizeof(head));
	memset(low,0,sizeof(low));
	memset(dfn,0,sizeof(dfn));
	memset(sccno,0,sizeof(sccno));
	memset(in,0,sizeof(in));
	memset(out,0,sizeof(out));
	memset(instack,false,sizeof(instack));
}
void tarjan(int u,int pre){
	int v;
	dfn[u]=low[u]=++dfs_clock;
	S.push(u);instack[u]=true;
	for(int k=head[u];k!=-1;k=A[k].next){
		v=A[k].to;
		if(!dfn[v]){
			tarjan(v,u);
			low[u]=MIN(low[u],low[v]);
		}
		else if(instack[v]){
			low[u]=MIN(low[u],dfn[v]);
		}
	}
	if(low[u]==dfn[u]){
		scc_cnt++;scc[scc_cnt].clear();
		G[scc_cnt].clear();
		while(1){
			v=S.top();S.pop();
			instack[v]=false;
			sccno[v]=scc_cnt;
			scc[scc_cnt].push_back(v);
			if(u==v)break;
		}
	}
}
void suodian(int m){
	for(int i=0;i<m;++i){
		int u=sccno[A[i].from];
		int v=sccno[A[i].to];
		if(u!=v){
			G[u].push_back(v);
			in[v]++;out[u]++;
		}
	}
}
int main()
{
	int i,j,k,n,m;
	while(scanf("%d",&n),n){
		init();scanf("%d",&m);
		for(i=0;i<m;++i){
			scanf("%d%d",&A[i].from,&A[i].to);
			A[i].next=head[A[i].from];
			head[A[i].from]=i;
		}
		for(i=1;i<=n;++i){
			if(!dfn[i])tarjan(i,-1);
		}
		suodian(m);
		int flag=0;scc[scc_cnt+1].clear();
		for(i=1;i<=scc_cnt;++i){
			if(out[i]==0){
				for(j=0;j<scc[i].size();++j){
					scc[scc_cnt+1].push_back(scc[i][j]);
				}
			}
		}
		sort(scc[scc_cnt+1].begin(),scc[scc_cnt+1].end());
		for(i=0;i<scc[scc_cnt+1].size();++i){
			if(i==0)
				printf("%d",scc[scc_cnt+1][i]);
			else 
				printf(" %d",scc[scc_cnt+1][i]);
		}
		printf("\n");
		
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值