hdoj5592ZYB's Premutation【线段树】

ZYB's Premutation

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 122    Accepted Submission(s): 42


Problem Description
ZYB  has a premutation  P ,but he only remeber the reverse log of each prefix of the premutation,now he ask you to 
restore the premutation.

Pair  (i,j)(i<j)  is considered as a reverse log if  Ai>Aj  is matched.
 

Input
In the first line there is the number of testcases T.

For each teatcase:

In the first line there is one number  N .

In the next line there are  N  numbers  Ai ,describe the number of the reverse logs of each prefix,

The input is correct.

1T5 , 1N50000
 

Output
For each testcase,print the ans.
 

Sample Input
  
  
1 3 0 1 2
 

Sample Output
  
  
3 1 2
 

Source
 

#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<cmath>
#include<algorithm>
#define lson l,mid,rt<<1
#define rson mid+1,r,rt<<1|1
using namespace std;
const int maxn=50010;
int num[maxn];
int ans[maxn];
int sum[maxn<<2];
void pushup(int rt){
	sum[rt]=sum[rt<<1]+sum[rt<<1|1];
}
void build(int l,int r,int rt){
	if(l==r){
		sum[rt]=1;
		return ;
	}
	int mid=(l+r)>>1;
	build(lson);
	build(rson);
	pushup(rt);
}
int query(int p,int l,int r,int rt){
	if(l==r){
		sum[rt]=0;
		return l;
	}
	int mid=(l+r)>>1;
	int pos;
	if(sum[rt<<1|1]>=p)pos=query(p,rson);
	else pos=query(p-sum[rt<<1|1],lson);
	pushup(rt);
	return pos;
}
int main()
{
	int t,i,j,k,n;
	scanf("%d",&t);
	while(t--){
		scanf("%d",&n);
		build(1,n,1);
		for(i=1;i<=n;++i){
			scanf("%d",&num[i]);
		}
		for(i=n;i>=1;--i){
			int p=num[i]-num[i-1]+1;
			ans[i]=query(p,1,n,1);
		}
		for(i=1;i<=n;++i){
			if(i==1){
				printf("%d",ans[i]);
			}
			else {
				printf(" %d",ans[i]);
			}
		}
		printf("\n");
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值