POJ3468 A Simple Problem with Integers 【线段树+lazy】

A Simple Problem with Integers
Time Limit: 5000MS Memory Limit: 131072K
Total Submissions: 74769 Accepted: 23006
Case Time Limit: 2000MS

Description

You have N integers, A1A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of AaAa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of AaAa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.
第一道用lazy思想的题对其实现过程还有一点小不理解以后多看看
#include<cstdio>
#include<cstdlib>
#include<cstring>
#define Max 100005
#define lson l,mid,rt<<1
#define rson mid+1,r,rt<<1|1
using namespace std;
__int64 sum[Max<<2];
__int64 add[Max<<2];
struct Node{
	__int64 l,r;
	__int64 m()
	{
		return (l+r)>>1;
	}
}tree[Max<<2];
void pushup(__int64 rt)
{
	sum[rt]=sum[rt<<1]+sum[rt<<1|1];
}
void pushdown(__int64 rt,__int64 mid)
{
	if(add[rt])
	{
		add[rt<<1]+=add[rt];
		add[rt<<1|1]+=add[rt];
		sum[rt<<1]+=add[rt]*(mid-(mid>>1));
		sum[rt<<1|1]+=add[rt]*(mid>>1);
		add[rt]=0;
	}
}
void buildtree(__int64 l,__int64 r,__int64 rt)
{
	tree[rt].l=l;
	tree[rt].r=r;
	add[rt]=0;
	if(tree[rt].l==tree[rt].r)
	{
		scanf("%I64d",&sum[rt]);
		return ;
	}
	__int64 mid=tree[rt].m();
	buildtree(lson);
	buildtree(rson);
	pushup(rt);
}
void update(__int64 a,__int64 b,__int64 c,__int64 rt)
{
	if(tree[rt].l==a&&tree[rt].r==b)
	{
		add[rt]+=c;
		sum[rt]+=c*(tree[rt].r-tree[rt].l+1);
		return ;
	}
	if(tree[rt].l==tree[rt].r)return ;
	pushdown(rt,tree[rt].r-tree[rt].l+1);
	__int64 mid=tree[rt].m();
	if(mid>=b)update(a,b,c,rt<<1);
	else if(mid<a)update(a,b,c,rt<<1|1);
	else
	{
		update(a,mid,c,rt<<1);
		update(mid+1,b,c,rt<<1|1);
	}
	pushup(rt);
}
__int64 query(__int64 a,__int64 b,__int64 rt)
{
	if(tree[rt].l==a&&tree[rt].r==b)
	return sum[rt];
	pushdown(rt,tree[rt].r-tree[rt].l+1);
	__int64 mid=tree[rt].m(),ans=0;
	if(mid>=b)ans+=query(a,b,rt<<1);
	else if(mid<a)ans+=query(a,b,rt<<1|1);
	else
	{
		ans+=query(a,mid,rt<<1);
		ans+=query(mid+1,b,rt<<1|1);
	}
	return ans;
}
int main()
{
	__int64 t,N,Q,i,a,b,c;
	char str[5]; 
	while(scanf("%I64d%I64d",&N,&Q)!=EOF)
	{
		buildtree(1,N,1);
		for(i=0;i<Q;++i)
		{
			scanf("%s",str);
			if(str[0]=='Q')
			{
				scanf("%I64d%I64d",&a,&b);
				printf("%I64d\n",query(a,b,1));
			}
			else
			{
				scanf("%I64d%I64d%I64d",&a,&b,&c);
				update(a,b,c,1);
			}
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值