hdoj1384Intervals【差分约束】

Intervals

  Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)  
  Total Submission(s): 3556    Accepted Submission(s): 1303


Problem Description
You are given n closed, integer intervals [ai, bi] and n integers c1, ..., cn.

Write a program that:

> reads the number of intervals, their endpoints and integers c1, ..., cn from the standard input,

> computes the minimal size of a set Z of integers which has at least ci common elements with interval [ai, bi], for each i = 1, 2, ..., n,

> writes the answer to the standard output
 

Input
The first line of the input contains an integer n (1 <= n <= 50 000) - the number of intervals. The following n lines describe the intervals. The i+1-th line of the input contains three integers ai, bi and ci separated by single spaces and such that 0 <= ai <= bi <= 50 000 and 1 <= ci <= bi - ai + 1.

Process to the end of file.

 

Output
The output contains exactly one integer equal to the minimal size of set Z sharing at least ci elements with interval [ai, bi], for each i = 1, 2, ..., n.
 

Sample Input
  
  
5 3 7 3 8 10 3 6 8 1 1 3 1 10 11 1
 

Sample Output
  
  
6
 

Author
1384
 
题意:给定多个区间[a,b]存在一个集合A在区间[a,b]内至少有c个数在集合A中求A中最少有多少个元素;
设S[i]为集合A在区间0到i中的元素个数则有题意知有在区间[a,b]对集合S中则满足S[b]-S[a-1]>=c;另有0=<S[i]-S[i-1]<=1;
既有S[a-1]-S[b]<=-c;S[i-1]-S[i]<=0;S[i]-S[i-1]<=1;
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#define inf 0x3f3f3f3f
using namespace std;
const int maxn=50010;
struct Node{
	int from,to,value;
	int next;
}A[maxn<<2];
int dist[maxn];
bool vis[maxn];
int head[maxn],node;
void init(){
	node=0;
	memset(vis,false,sizeof(vis));
	memset(head,-1,sizeof(head));
	memset(dist,0x3f,sizeof(dist));
}
void add(int u,int v,int value){
	A[node].from=u;
	A[node].to=v;
	A[node].value=value;
	A[node].next=head[u];
	head[u]=node++;
}
int spfa(int minl,int maxr){
	int i,j,k,u;
	queue<int>Q;
	dist[maxr]=0;
	vis[maxr]=true;
	Q.push(maxr);
	while(!Q.empty()){
		u=Q.front();Q.pop();vis[u]=false;
		for(k=head[u];k!=-1;k=A[k].next){
			int v=A[k].to;
			if(dist[v]>dist[u]+A[k].value){
				dist[v]=dist[u]+A[k].value;
				if(!vis[v]){
					vis[v]=true;
					Q.push(v);
				}
			}
		}
	}
	return -dist[minl-1];
}
int main()
{
	int n,i,j,k;
	while(scanf("%d",&n)!=EOF){
		int a,b,c;init();
		int minl=inf,maxr=0;
		for(i=0;i<n;++i){
			scanf("%d%d%d",&a,&b,&c);
			add(b,a-1,-c);
			minl=min(minl,a);
			maxr=max(maxr,b);
		}
		for(i=minl;i<=maxr;++i){
			add(i-1,i,1);
			add(i,i-1,0);
		}
		printf("%d\n",spfa(minl,maxr));
	}
	return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值