hdoj4283You Are the One【区间dp】

You Are the One

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2659    Accepted Submission(s): 1229


Problem Description
  The TV shows such as You Are the One has been very popular. In order to meet the need of boys who are still single, TJUT hold the show itself. The show is hold in the Small hall, so it attract a lot of boys and girls. Now there are n boys enrolling in. At the beginning, the n boys stand in a row and go to the stage one by one. However, the director suddenly knows that very boy has a value of diaosi D, if the boy is k-th one go to the stage, the unhappiness of him will be (k-1)*D, because he has to wait for (k-1) people. Luckily, there is a dark room in the Small hall, so the director can put the boy into the dark room temporarily and let the boys behind his go to stage before him. For the dark room is very narrow, the boy who first get into dark room has to leave last. The director wants to change the order of boys by the dark room, so the summary of unhappiness will be least. Can you help him?
 

Input
  The first line contains a single integer T, the number of test cases.  For each case, the first line is n (0 < n <= 100)
  The next n line are n integer D1-Dn means the value of diaosi of boys (0 <= Di <= 100)
 

Output
  For each test case, output the least summary of unhappiness .
 

Sample Input
  
  
2    5 1 2 3 4 5 5 5 4 3 2 2
 

Sample Output
  
  
Case #1: 20 Case #2: 24
 
很好的区间dp想法很重要。看着别人的AC代码思考了很久才慢慢理解很抽象。
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#include<list>
#include<vector>
#define inf 0x3f3f3f3f
using namespace std;
const int maxn=10010;
int num[maxn],sum[maxn];
int dp[maxn][maxn];
int main()
{
	int t,n,m,test=1;
	scanf("%d",&t);
	while(t--){
		scanf("%d",&n);
		for(int i=1;i<=n;++i){
			scanf("%d",&num[i]);
			sum[i]=sum[i-1]+num[i];
		}
		for(int len=2;len<=n;++len){//区间长度 
			for(int i=1;i+len<=n+1;++i){//区间以第i人开始 以i+len-1人结束 
				int j=i+len-1;dp[i][j]=inf;
				for(int k=i;k<=j;++k){//第i人在区间i到j中在第k-i+1个出场 
					dp[i][j]=min(dp[i][j],dp[i+1][k]+dp[k+1][j]+(k-i)*num[i]+(k-i+1)*(sum[j]-sum[k]));
					/**************************************************************************************
					考虑在区间i到j中因为i在区间第1个位置,因此要让i在第k-i+1个出场则有在它前面要先出去k-i个人
					即在i后面先出去k-i个人即要加上dp[i+1][k]区间中剩下的人要在i人出场之后才能出场所以将剩下的人考虑
					在区间dp[k+1][j]中显然区间dp[k+1][j]中的每个人都已经等了k-i+1个人所以要在加上(k-i+1)*(sum[j]-sum[k])
					****************************************************************************************************/ 
				}
			}
		}
		printf("Case #%d: %d\n",test++,dp[1][n]);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值