HDU5475An easy problem(线段树单点更新)

An easy problem

Time Limit: 8000/5000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2077    Accepted Submission(s): 853


Problem Description
One day, a useless calculator was being built by Kuros. Let's assume that number X is showed on the screen of calculator. At first, X = 1. This calculator only supports two types of operation.
1. multiply X with a number.
2. divide X with a number which was multiplied before.
After each operation, please output the number X modulo M.
 

Input
The first line is an integer T( 1T10 ), indicating the number of test cases.
For each test case, the first line are two integers Q and M. Q is the number of operations and M is described above. ( 1Q105,1M109 )
The next Q lines, each line starts with an integer x indicating the type of operation.
if x is 1, an integer y is given, indicating the number to multiply. ( 0<y109 )
if x is 2, an integer n is given. The calculator will divide the number which is multiplied in the nth operation. (the nth operation must be a type 1 operation.)

It's guaranteed that in type 2 operation, there won't be two same n.
 

Output
For each test case, the first line, please output "Case #x:" and x is the id of the test cases starting from 1.
Then Q lines follow, each line please output an answer showed by the calculator.
 

Sample Input
  
  
1 10 1000000000 1 2 2 1 1 2 1 10 2 3 2 4 1 6 1 7 1 12 2 7
 

Sample Output
  
  
Case #1: 2 1 2 20 10 1 6 42 504 84




题目大意:给X赋初值1,然后给Q个操作,每个操作对应一个整数M;如果操作是1则将X乘以对应的M,如果是2则除以第M次操作对应的M',求最后X的值对给定值取摸的结果。(注意只有输出的时候才取模)


分析:一开始没注意到输出时候才去模所以就直接做了。但是看到输出结果时才取模,发现直接做显然是不行的。

正解是用每一次的操作为节点,建立线段树,每个节点存放第i次的操作。1操作可以表示为节点的值变为num,2操作可以将节点的值变为1,然后每次操作完后输出根结点的值,这样我们就把除法操作变为乘法操作了。

另外,这题也可以暴力直接做。


关键还是得想到用线段树做!

#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
typedef long long ll;
const int maxn = 1e5+5;
ll segTree[maxn<<2], mod;
void pushup(int rt)
{
    segTree[rt] = segTree[rt<<1] * segTree[rt<<1|1] % mod;
}
void build(int l, int r, int rt)
{
    if(l == r)
    {
        segTree[rt] = 1;
        return ;
    }
    int mid = (l+r)>>1;
    build(l, mid, rt<<1);
    build(mid+1, r, (rt<<1)|1);
    pushup(rt);
}
void update(int pos, ll val, int l, int r, int rt)
{
    if(l == r)
    {
        segTree[rt] = val;
        return ;
    }
    int mid = (l+r) >> 1;
    if(pos <= mid)
        update(pos, val, l, mid, rt<<1);
    else
        update(pos, val, mid+1, r, rt<<1|1);
    pushup(rt);
}
int main()
{
    int T, q;
    ll op, num;
    scanf("%d", &T);
    for(int kase = 1; kase <= T; kase++)
    {
        scanf("%d%lld", &q, &mod);
        build(1, q, 1);
        printf("Case #%d:\n", kase);
        for(int i = 1; i <= q; i++)
        {
            scanf("%lld%lld", &op, &num);
            if(op == 1)
                update(i, num, 1, q, 1);
            else
                update(num, 1, 1, q, 1);
            printf("%lld\n", segTree[1]);
        }
    }
    return 0;
}







  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值