poj2236 Wireless Network

Wireless Network

An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B.

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations.

Input

The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats:
1. "O p" (1 <= p <= N), which means repairing computer p.
2. "S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate.

The input will not exceed 300000 lines.

Output

For each Testing operation, print "SUCCESS" if the two computers can communicate, or "FAIL" if not.

Sample Input

4 1

0 1

0 2

0 3

0 4

O 1

O 2

O 4

S 1 4

O 3

S 1 4

Sample Output

FAIL

SUCCESS

 

题意:

有一个计算机网络的所有线路都坏了,网络中有n台计算机,现在你可以做两种操作,修理(O)和检测两台计算机是否连通(S),只有修理好的计算机才能连通。连通有个规则,两台计算机的距离不能超过给定的最大距离D(一开始会给你n台计算机的坐标)。检测的时候输出两台计算机是否能连通。

思路:

  每次修理好一台计算机的时候就遍历一下所有修好的计算机,看距离是否<=D,如果符合说明可以连通,将两台计算机所在集合合并。

  每次检查的时候判断一下这两台计算机是否在同一集合中即可。

 

 

#include<algorithm>

#include<iostream>

#include<cstdio>

#include<cmath>

using namespace std;

 

int N,d;

struct zuobiao

{

    int pre;

    int q,w;

    bool mark;

}e[1008];

int Find(int m)

{

    if(m==e[m].pre)

        return m;

    int t=Find(e[m].pre);

    return e[m].pre=t;

}

 

void Merge(zuobiao p1,zuobiao p2)

{

    int fx=Find(p1.pre);

    int fy=Find(p2.pre);

    if(fx!=fy)

        e[fy].pre=fx;

}

 

bool juli(zuobiao a,zuobiao b)

{

    int q=a.q-b.q;

    int w=a.w-b.w;

    if (q*q+w*w<=d*d)

        return true;

    else

        return false;

}

int main()

{

    scanf("%d%d",&N,&d);

    int i;

    for(i=1;i<=N;i++)

    {

        scanf("%d%d",&e[i].q,&e[i].w);

        e[i].mark=false;

        e[i].pre=i;

    }

    char c;

    while(cin>>c)

    {

        if(c=='O')

        {

            int x;

            scanf("%d",&x);

            e[x].mark=true;

            for(i=1;i<=N;i++)

            {

                if(e[i].mark&&juli(e[i],e[x])&&i!=x)//维修过且距离小于d

                {

                    Merge(e[i],e[x]);

                }

            }

        }

        if(c=='S')

        {

            int a,b;

            scanf("%d%d",&a,&b);

            if(Find(a)==Find(b))//有相同的根

            {

                printf("SUCCESS\n");

            }

            else

                printf("FAIL\n");

        }

    }

    return 0;

}

 

注意:输入需要注意的地方、字符用scanf输入就是错的 用cin输入是对的

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值