poj1458 Common Subsequence

9 篇文章 0 订阅

Common Subsequence

Time Limit: 1000MS

 

Memory Limit: 10000K

Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.

Input

The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.

Output

For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input

abcfbc         abfcab

programming    contest

abcd           mnp

Sample Output

4

2

0

 

题意:最长公共子序列

#include <iostream>

#include <algorithm>

#include <cstring>

#include <cstdio>

using namespace std;

char s1[1005],s2[1005];

int dp[1005][1005];

int l1,l2;

int main()

{

    while(cin>>s1>>s2)

    {

        l1=strlen(s1);

        l2=strlen(s2);//字符串长度

        memset(dp,0,sizeof(dp));//先将数组清零

        for(int i=1;i<=l1;i++)

        {

            for(int j=1;j<=l2;j++)

            {

                if(s1[i-1]==s2[j-1])//从第一个字符开始

                    dp[i][j]=dp[i-1][j-1]+1;

                else

                    dp[i][j]=max(dp[i-1][j],dp[i][j-1]);

            }

        }

        cout<<dp[l1][l2]<<endl;

    }

    return 0;

}

 

有不明白的小伙伴可以看看这个大佬写的博客(最长公共子序列 动态规划图解) 思路很清楚

网址:http://blog.csdn.net/hrn1216/article/details/51534607

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值