poj 2386 Lake Counting (DFS或BFS)

Language:Default

Lake Counting

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 41740 Accepted: 20708

Description

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors. 

Given a diagram of Farmer John's field, determine how many ponds he has.

Input

* Line 1: Two space-separated integers: N and M 

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.

Output

* Line 1: The number of ponds in Farmer John's field.

Sample Input

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output

3

 

题意:寻找图中有多少条河

思路:dfs和bfs都可以解决,解为bfs或dfs的次数,遇到‘W’,就把它置为‘.’

dfs AC代码:

#include <cstdio>
#include <vector>
#include <queue>
#include <cstring>
using namespace std;
const int MAXN = 100+10;
char mp[MAXN][MAXN];
bool used[MAXN][MAXN];
int n,m;
int dir[8][2]={{-1,-1},{-1,0},{-1,1},{0,-1},{0,1},{1,-1},{1,0},{1,1}};

void init(){
	memset(used,false,sizeof(used));
	for(int i=0;i<MAXN;i++){
		for(int j=0;j<MAXN;j++){
			mp[MAXN][MAXN]='\0';
		}
	}
}
void Myscanf(){
	getchar();
	for(int i=0;i<n;i++){
		for(int j=0;j<m;j++){
			scanf("%c",&mp[i][j]);
		}
		getchar();		
	}
}
void dfs(int i,int j){
	used[i][j]=true;
	mp[i][j]='.';
	for(int k=0;k<8;k++){
		int di=i+dir[k][0];
		int dj=j+dir[k][1];
		if(di>=0 && di<n && dj>=0 && dj<m && used[di][dj]==false && mp[di][dj]=='W'){
			dfs(di,dj);
		}
	}
}
void solve(){
	int ans=0;
	for(int i=0;i<n;i++){
		for(int j=0;j<m;j++){
			if(mp[i][j]=='W' && used[i][j]==false){
				ans++;
				dfs(i,j);	
			}
		}
	}
	printf("%d\n",ans);
}
int main(){
	while(~scanf("%d%d",&n,&m)){
		init();
		Myscanf();
		solve();
	}
	return 0;	
}

bfs AC代码:

#include <cstdio>
#include <cstring>
#include <vector>
#include <queue>
using namespace std;
const int MAXN =100+10;
int n,m;
char G[MAXN][MAXN];
int dir[8][2]={{-1,-1},{-1,0},{-1,1},{0,-1},{0,1},{1,-1},{1,0},{1,1}};
typedef pair<int,int> P;
queue<P> que;
void init(){
	while(!que.empty()){
		que.pop();
	}
	memset(G,'\0',sizeof(G));
}
void Myscanf(){
	getchar();
	int a,b;
	for(int i=0;i<n;i++){
		for(int j=0;j<m;j++){
			scanf("%c",&G[i][j]);
		}
		getchar();
	}
}

void bfs(P node){
	while(!que.empty()){
		P temp=que.front();
		G[temp.first][temp.second]='.';
		que.pop();
		for(int i=0;i<8;i++){
			int di=temp.first+dir[i][0];
			int dj=temp.second+dir[i][1];
			if(G[di][dj]=='W'){
				G[di][dj]='.';
				que.push(P(di,dj));
			}
		}
	}
}
void solve(){
	int ans=0;
	for(int i=0;i<n;i++){
		for(int j=0;j<m;j++){
			if(G[i][j]=='W'){
				ans++;
				G[i][j]='.';
				que.push(P(i,j));
				bfs(P(i,j));
			}
		}
	}
	printf("%d\n",ans);
}
int main(){
	while(~scanf("%d%d",&n,&m)){
		init();
		Myscanf();
		solve();
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值