HDU 2069 Coin Change

Problem Description
Suppose there are 5 types of coins: 50-cent, 25-cent, 10-cent, 5-cent, and 1-cent. We want to make changes with these coins for a given amount of money.

For example, if we have 11 cents, then we can make changes with one 10-cent coin and one 1-cent coin, or two 5-cent coins and one 1-cent coin, or one 5-cent coin and six 1-cent coins, or eleven 1-cent coins. So there are four ways of making changes for 11 cents with the above coins. Note that we count that there is one way of making change for zero cent.

Write a program to find the total number of different ways of making changes for any amount of money in cents. Your program should be able to handle up to 100 coins.
 

Input
The input file contains any number of lines, each one consisting of a number ( ≤250 ) for the amount of money in cents.
 

Output
For each input line, output a line containing the number of different ways of making changes with the above 5 types of coins.
 

Sample Input
  
  
11 26
 

Sample Output
  
  
4 13
 

//枚举
#include <stdio.h>
#include <string.h>
#define maxn 251
int main()
{
	int i, j, k, m, n,sum,t;
	int d[maxn],count[maxn];
	memset(count, 0, sizeof(count));
	count[0] = 1;
	for (i = 1;i < maxn;i++) {
		d[i] = i;//d[i]代表i美分
		for (j = 0;j <= d[i] / 50;j++) {
			for (k = 0;k <= d[i] / 25;k++) {
				for (m = 0;m <= d[i] / 10;m++) {
					for (n = 0;n <= d[i] / 5;n++) {
						sum = 50 * j + 25 * k + 10 * m + 5 * n;
						t=j + k + m + n;
						if (sum <= d[i] && (t + d[i] - sum <= 100)) count[i]++;
					}
				}
			}
		}
	}
	int x;
	while (~scanf("%d", &x)) {
		printf("%d\n", count[x]);
	}
	return 0;
}
//母函数
#include <stdio.h>
#include <string.h>
#define maxn 251
int main()
{
	int c1[maxn][110], c2[maxn][110], i, j, k, l, c[maxn];
	//c1,c2多开一维是为了判别总的硬币数量是否超过100
	//c1[i][j]表示i美分时需要j枚硬币,c[i]表示i美分时方案数
	int a[6] = { 0,1,5,10,25,50 }, b[6];//数组a保存可选硬币种类,数组b保存每种硬币最多可选个数
	memset(c1, 0, sizeof(c1));
	memset(c2, 0, sizeof(c2));
	memset(c, 0, sizeof(c));
	c1[0][0] = 1;
	for (i = 1;i <= 5;i++) {
		for (j = 0;j <= 250;j++)
			for (k = 0;k*a[i] + j <= 250;k++)//新加入的硬币个数k个
				for (l = 0;l + k <= 100;l++)//l是原先已用硬币数
				c2[k*a[i] + j][l+k] += c1[j][l];//有可能出现c1[j][l]为0,此时l个硬币得不到j美分
		memcpy(c1, c2, sizeof(c1));
		memset(c2, 0, sizeof(c2));
	}
	for (i = 1;i <= 250;i++)
		for (j = 0;j <= 100;j++)
			c[i] += c1[i][j];//将满足凑成i美分时所用硬币数<=100的方案数累加
	c[0] = 1;//题目要求0美分时是一种方案
	int n;
	while (~scanf("%d", &n)) {
		printf("%d\n", c[n]);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值