HDU 1253 - 胜利大逃亡(BFS)

2017.12.6对BFS的系列练习的第二题。
传送门:http://acm.hdu.edu.cn/showproblem.php?pid=1253
胜利大逃亡

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 39809 Accepted Submission(s): 13957

Problem Description
Ignatius被魔王抓走了,有一天魔王出差去了,这可是Ignatius逃亡的好机会.

魔王住在一个城堡里,城堡是一个A*B*C的立方体,可以被表示成A个B*C的矩阵,刚开始Ignatius被关在(0,0,0)的位置,离开城堡的门在(A-1,B-1,C-1)的位置,现在知道魔王将在T分钟后回到城堡,Ignatius每分钟能从一个坐标走到相邻的六个坐标中的其中一个.现在给你城堡的地图,请你计算出Ignatius能否在魔王回来前离开城堡(只要走到出口就算离开城堡,如果走到出口的时候魔王刚好回来也算逃亡成功),如果可以请输出需要多少分钟才能离开,如果不能则输出-1.

这里写图片描述

Input
输入数据的第一行是一个正整数K,表明测试数据的数量.每组测试数据的第一行是四个正整数A,B,C和T(1<=A,B,C<=50,1<=T<=1000),它们分别代表城堡的大小和魔王回来的时间.然后是A块输入数据(先是第0块,然后是第1块,第2块……),每块输入数据有B行,每行有C个正整数,代表迷宫的布局,其中0代表路,1代表墙.(如果对输入描述不清楚,可以参考Sample Input中的迷宫描述,它表示的就是上图中的迷宫)

特别注意:本题的测试数据非常大,请使用scanf输入,我不能保证使用cin能不超时.在本OJ上请使用Visual C++提交.

Output
对于每组测试数据,如果Ignatius能够在魔王回来前离开城堡,那么请输出他最少需要多少分钟,否则输出-1.

Sample Input
1
3 3 4 20
0 1 1 1
0 0 1 1
0 1 1 1
1 1 1 1
1 0 0 1
0 1 1 1
0 0 0 0
0 1 1 0
0 1 1 0

Sample Output
11

很轻松的三维BFS,注意一下x, y, z轴的方向。x轴是层数。
AC代码如下:

#include <cstdio>
#include <cstring>
#include <queue>
using namespace std;
const int maxn = 50;
int a, b, c;
int t;
int ex, ey, ez;
int ca[maxn][maxn][maxn];
int vis[maxn][maxn][maxn];
int dx[6] = {1, -1, 0, 0, 0, 0};
int dy[6] = {0, 0, 1, -1, 0, 0};
int dz[6] = {0, 0, 0, 0, 1, -1};

struct Node{
    int x, y, z;
    int step;
};

int BFS(void)
{
    memset(vis, 0, sizeof(vis));
    queue<Node> I;
    Node beg;
    beg.x = beg.y = beg.z = beg.step = 0;
    I.push(beg);
    vis[beg.x][beg.y][beg.z] = 1;

    while(!I.empty())
    {
        Node cur = I.front();
        I.pop();
        if(cur.step > t)    return -1;
        if(cur.x == ex && cur.y == ey && cur.z == ez)    return cur.step;

        for(int i = 0; i < 6; i++)
        {
            Node next;
            next.x = cur.x + dx[i];
            next.y = cur.y + dy[i];
            next.z = cur.z + dz[i];
            next.step = cur.step + 1;

            if(next.x < 0 || next.x >= a || next.y < 0 || next.y >= b || next.z < 0 || next.z >= c)    continue;
            if(vis[next.x][next.y][next.z] || ca[next.x][next.y][next.z])    continue;
            if(next.step > t)    continue;

            if(next.x == ex && next.y == ey && next.z == ez)    return next.step;
            vis[next.x][next.y][next.z] = 1;
            I.push(next);


        }
    } 
    return -1;
}

int main()
{
    int kase;
    scanf("%d", &kase);
    while(kase--)
    {
        scanf("%d %d %d %d", &a, &b, &c, &t);
        for(int h = 0; h < a; h++)
            for(int i = 0; i < b; i++)
                for(int j = 0; j < c; j++)
                    scanf("%d", &ca[h][i][j]);

        ex = a - 1;
        ey = b - 1; 
        ez = c - 1;
        printf("%d\n", BFS());
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值