尺取 模板 POJ-3061

题目:

Subsequence
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 17579 Accepted: 7483

Description

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.

Input

The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.

Output

For each the case the program has to print the result on separate line of the output file.if no answer, print 0.

Sample Input

2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5

Sample Output

2
3

题意:给定长度为n的数列,整数s。求总和不小于s的连续子序列长度最小值 。若解不存在,输出0。

方法:尺取。若下标为i~j的区间为最初的总和大于S的连续子序列,那么一定有性质:(i+1)~j 之和 < s 。

则若以下标i为起点的序列之和比s小,j就一直向后,并使序列之和加上j对应的数列元素。若j直到数列最后都没能使和大于s,则搜索结束。

当序列满足>=s的条件时,由于要保证序列长度最小,j停止移动,并检查满足条件的最小序列长度,更新。以i为起点的连续序列搜索结束。

之后由于上述性质,搜索以i+1为起点的序列时,j保持之前的位置即可。

代码:

#include<cstdio>
#include<cstdlib>
#include<cmath>
#include<cstring>
#include<iostream>
#include<algorithm>
#define sd(x) scanf("%d",&x)
#define ss(x) scanf("%s",x)
#define sc(x) scanf("%c",&x)
#define sf(x) scanf("%f",&x)
#define slf(x) scanf("%lf",&x)
#define slld(x) scanf("%lld",&x)
#define me(x,b) memset(x,b,sizeof(x))
#define pd(d) printf("%d\n",d);
#define plld(d) printf("%lld\n",d);

typedef long long ll;

using namespace std;

const int INF = 0x3f3f3f3f;

int a[100010];

int main(){
	ios::sync_with_stdio(false);
	int t;
	cin>>t;	
	while(t--){
		int n,s;
		int ans = INF;
		cin>>n>>s;
		for(int i = 1 ; i<=n ; i++){
			cin>>a[i];
		}
		int i = 1,j = 1;//i为序列的首,j为序列的尾 
		int sum = 0;
		
		while(1){
			while(j<=n && sum<s){ //找到第一个末位置使序列之和大于s 
				sum+=a[j];
				j++;
			} 
			if(sum<s)	break;    //从i一直到给出数列的尾部的所有和都不能大于等于s的情况,
								  //之后的所有和只可能比当前小,退出 
			
			ans = min(ans,j-i);
			sum -= a[i];
			i++; 
		} 
		
		
		if(ans == INF){
			ans = 0;
		}
	
		cout<<ans<<endl;

	}
	return 0;
}





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值