HDOJ 1789 Doing Homework again

Doing Homework again
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

zichen has just come back school from the 30th ACM/ ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If zichen hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So zichen wants you to help him to arrange the order of doing homework to minimize the reduced score.

Input

The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow. 
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.

Output

For each test case, you should output the smallest total reduced score, one line per test case.

Sample Input

	
3
3
3 3 3
10 5 1
3
1 3 1
6 2 3
7
1 4 6 4 2 4 3
3 2 1 7 6 5 4 

Sample Output

	
0
3
5 
题意不难懂。先按照扣除学分的分值从大到小排序,再对天数经行操作,标记能在规定天数内完成的学科。将不能完成的学科学分相加即可。具体代码如下:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct node
{
	int time;
	int score;
}a[1010];
int b[1010];
int cmp(node x,node y)
{
	return x.score>y.score; 
}
int main()
{
	int t,n;
	scanf("%d",&t);
	while(t--)
	{
		memset(b,0,sizeof(b));
		scanf("%d",&n);
		for(int i=0;i<n;i++)
		{
			scanf("%d",&a[i].time);
		}
		for(int i=0;i<n;i++)
		{
			scanf("%d",&a[i].score);
		}
		sort(a,a+n,cmp);
		int count=0;
		for(int i=0;i<n;i++)
		{
			int sign=0;
			for(int j=a[i].time;j>0;j--)//查找做当前作业可用的时间,若没有则完不成当前作业; 
			{                           //若a[i].time=4;从1扫到4,若b[1]-b[4]都为1,则作业完不成; 
				if(b[j]==0)
				{
					b[j]=1;
					sign=1;
					break;
				}
			}
			if(!sign)
			   count+=a[i].score;
		}
		printf("%d\n",count);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值