HDOJ Doing Homework again (贪心+优先队列)

Doing Homework again

Time Limit : 1000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 31   Accepted Submission(s) : 25
Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
 

Input
The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.
 

Output
For each test case, you should output the smallest total reduced score, one line per test case.
 

Sample Input
  
  
3 3 3 3 3 10 5 1 3 1 3 1 6 2 3 7 1 4 6 4 2 4 3 3 2 1 7 6 5 4
 

Sample Output
  
  
0 3 5 大意:就是一个人做家庭作业,如果在规定日期内做不完会受到惩罚,求受到最少的惩罚的是多少 刚开始用贪心的思想求,没求出来(汗= =,然后一列,嘿,这不是优先队列就行了吗!然后就是这样,从期限最早的开始入队(当然,先排序),然后遍历,如果队列中数目 少于将要入队的期限数,直接入队,如果不少于,那就要判断是否要踢人了,毕竟这关系到他受惩罚的多少嘛,这就看优先队列了,总是把惩罚最小的人提出来比较,如果他惩罚 小于比较的惩罚,那么他出队,另一个入队。以此类推。。。。 ac代码:  
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<queue>
#include<algorithm>
#define MAXN 1010
using namespace std;
struct s
{
    int time;
    int score;
    friend bool operator<(s aa,s bb)
    {
        return aa.score>bb.score;
    }
}a[MAXN],d;
bool cmp(s a,s b)
{
    if(a.time==b.time)//注意:是按时间排序
    return a.score<b.score;
    return a.time<b.time;
}
priority_queue<s>q;
int main()
{
    int t,i,n;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(i=0;i<n;i++)
        scanf("%d",&a[i].time);
        for(i=0;i<n;i++)
        scanf("%d",&a[i].score);
        sort(a,a+n,cmp);
        int sum=0;
        for(i=0;i<n;i++)
        {
            if(q.size()<a[i].time)
            q.push(a[i]);
            else
            {
                d=q.top();
                if(d.score<a[i].score)
                {
                    q.pop();
                    q.push(a[i]);
                    sum+=d.score;
                }
                else
                {
                    sum+=a[i].score;
                }
            }
        }
        printf("%d\n",sum);
        while(!q.empty())
        {
            q.pop();
        }
    }
    return 0;
}

不是优先队列的方法
学长的ac代码:
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn = 1010;
struct hw
{
	int score,date;
}arr[maxn];
bool mark[maxn];
int n;

bool cmp(hw x,hw y)		//分数相同,按日期从小到大排序,否则按分数从大到小排序 
{
	if(x.score==y.score) return x.date<y.date;
	else return x.score>y.score;
}

int main()
{
	int t,i,j,sum,day;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		for(i=0;i<n;++i)
			scanf("%d",&arr[i].date);
		for(i=0;i<n;++i)
			scanf("%d",&arr[i].score);
		sort(arr,arr+n,cmp);
		memset(mark,0,sizeof(mark));	//标记数组清零 
		sum=0;
		for(i=0;i<n;++i)		//按顺序,从截止日期开始往前找没有占用掉的时间,如果找不到,就加到总和里。 
		{
			day=arr[i].date;
			for(j=day;j>0;j--)
			{
				if(!mark[j])
				{
					mark[j]=true;
					break;
				}
			}
			if(j==0)
				sum+=arr[i].score;
		}
		printf("%d\n",sum);
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值