HDU 3308 LCIS

Problem Description
Given n integers.
You have two operations:
U A B: replace the Ath number by B. (index counting from 0)
Q A B: output the length of the longest consecutive increasing subsequence (LCIS) in [a, b].

Input
T in the first line, indicating the case number.
Each case starts with two integers n , m(0 < n,m<=105).
The next line has n integers(0<=val<=105).
The next m lines each has an operation:
U A B(0<=A,n , 0<=B=105)
OR
Q A B(0<=A<=B< n).

Output
For each Q, output the answer.

Sample Input
1
10 10
7 7 3 3 5 9 9 8 1 8
Q 6 6
U 3 4
Q 0 1
Q 0 5
Q 4 7
Q 3 5
Q 0 2
Q 4 6
U 6 10
Q 0 9

Sample Output
1
1
4
2
3
1
2
5


这题。。说多了都是泪。
算法好想,没有坑点,异常复杂。
容我整理思路,来日更博。(删除)
上神犇博客这里


#include<iostream>
#include<cstdio>
using namespace std;
const int maxn=100005;
int t,n,m,data[maxn];
struct node
{
    int l,r,ln,rn,lm,rm,mx;
}a[4*maxn];
void update(int num)
{
    a[num].ln=a[2*num].ln;
    a[num].rn=a[2*num+1].rn;
    a[num].lm=a[2*num].lm;
    a[num].rm=a[2*num+1].rm;
    a[num].mx=max(a[2*num].mx,a[2*num+1].mx);
    if(a[2*num].rn<a[2*num+1].ln)
    {
        if(a[2*num].lm==a[2*num].r-a[2*num].l+1)
            a[num].lm+=a[2*num+1].lm;
        if(a[2*num+1].rm==a[2*num+1].r-a[2*num+1].l+1)
            a[num].rm+=a[2*num].rm;
        a[num].mx=max(a[num].mx,a[2*num].rm+a[2*num+1].lm);
    }
}
void build(int num,int l,int r)
{
    a[num].l=l;
    a[num].r=r;
    if(l==r)
    {
        a[num].lm=a[num].rm=a[num].mx=1;
        a[num].ln=a[num].rn=data[l];
        return ;
    }
    int mid=l+r>>1;
    build(2*num,l,mid);
    build(2*num+1,mid+1,r);
    update(num);
}
void chg(int num,int p,int s)
{
    if(a[num].l==a[num].r)
    {
        a[num].ln=a[num].rn=s;
        return ;
    }
    int mid=a[num].l+a[num].r>>1;
    if(p<=mid)
        chg(2*num,p,s);
    else
        chg(2*num+1,p,s);
    update(num);
}
int query(int num,int l,int r)
{
    if(l<=a[num].l&&r>=a[num].r)
        return a[num].mx;
    int ans=0,mid=a[num].l+a[num].r>>1;
    if(l<=mid)
        ans=max(ans,query(2*num,l,r));
    if(r>=mid+1)
        ans=max(ans,query(2*num+1,l,r));
    if(a[2*num].rn<a[2*num+1].ln)
        ans=max(ans,min(mid-l+1,a[2*num].rm)+min(r-mid,a[2*num+1].lm));
    return ans;
}
int main()
{
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        for(int i=1;i<=n;i++)
            scanf("%d",&data[i]);
        build(1,1,n);
        char ch[11];
        int l,r;
        while(m--)
        {
            scanf("%s%d%d",ch,&l,&r);
            if(ch[0]=='Q')
                printf("%d\n",query(1,l+1,r+1));
            else
                chg(1,l+1,r);
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值