2.7-3 Android Studio 的Gradle一点理解, 查看gradle 版本和android 插件的版本

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/Rodulf/article/details/50679928

参考:https://developer.android.com/studio/releases/gradle-plugin.html


gradle 最大的优点就是对依赖管理的强力支持;

查看gradle 版本和android 插件的版本

File->Project Structure->Project



首先要注意的是在android studio 里面的gradle 有两个部分

1:作为插件的gradle

2:gradle的包

(可以这样记忆,就像mysql,和mysql的连接的插件,记住这个只是个人为了方便记忆这样去记哦)


1: 作为插件的gradle 是在

Gradle 文件里面下面的这个是gradle给android studio的插件。
build.gradle 里面的classpath 'com.android.tools.build:gradle:1.5.0'




2: 作为gradle包的gradle 是在这里

Android Studio 里面配置的地方在这里:
需要注意可以有两种方法:
第一种是用wrapper的方法,也是android studio 推荐的方法,它会自动的去下载
第二种是手动下载后指定位置


在Project 暂时目录下面的gradle目录下面的wrapper目录下面的gradle-wrapper.properties文件中配置信息:

#Wed Oct 21 11:34:03 PDT 2015

distributionBase=GRADLE_USER_HOME

distributionPath=wrapper/dists

zipStoreBase=GRADLE_USER_HOME

zipStorePath=wrapper/dists

distributionUrl=https\://services.gradle.org/distributions/gradle-2.8-all.zip

可以修改最后的一行。

如果执行成功了在Project 的展示的时候显示的目录下面会有一个.gradle->2.8

2.2: 就是手动的去下载

下载地址就是这个:https://services.gradle.org/distributions/

参考: Android gradle 手动下载(注意不是Android Gradle Plugin)



3: Gradle Plugin 和 Gradle的版本的需求

例如这里如果plugin是2.3.0的那么Gradle 就至少是3.3的

参考官方网站,选择合适的https://developer.android.com/studio/releases/gradle-plugin.html#updating-plugin

Plugin version Required Gradle version
1.0.0 - 1.1.3 2.2.1 - 2.3
1.2.0 - 1.3.1 2.2.1 - 2.9
1.5.0 2.2.1 - 2.13
2.0.0 - 2.1.2 2.10 - 2.13
2.1.3 - 2.2.3 2.14.1+
2.3.0+ 3.3+



++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++



BTW:
在第一种方式中:
------------------------------
我把1.5.0改成了1.8.0就报错了。最后还是还原到了1.5.0,

网上还有gradle 插件版本是2.0.0 的遇到错误的:com.android.tools.build:gradle:2.0.0-alpha3 build errors


    dependencies {
        classpath 'com.android.tools.build:gradle:1.8.0'


        // NOTE: Do not place your application dependencies here; they belong
        // in the individual module build.gradle files
    }
------------------------------
Gradle 'LuoPanDemo' project refresh failed
Error:Could not find com.android.tools.build:gradle:1.8.0.
Searched in the following locations:
    file:/C:/Android/Android Studio/gradle/m2repository/com/android/tools/build/gradle/1.8.0/gradle-1.8.0.pom
    file:/C:/Android/Android Studio/gradle/m2repository/com/android/tools/build/gradle/1.8.0/gradle-1.8.0.jar
    https://jcenter.bintray.com/com/android/tools/build/gradle/1.8.0/gradle-1.8.0.pom
    https://jcenter.bintray.com/com/android/tools/build/gradle/1.8.0/gradle-1.8.0.jar
Required by:
    :LuoPanDemo:unspecified

我注意到有这样类似的目录:
C:\Android\Android Studio\gradle\m2repository\com\android\tools\build\gradle\1.3.0
----------------------------------------------


一些知识点:

http://ask.android-studio.org/?/article/7
Very powerful dependency management (based on Apache Ivy).
<翻译>对依赖管理的强力支持(基于Apache Ivy)。
http://ask.android-studio.org/?/article/10
大概来说,依赖管理由两方面构成。一方面,Gradle需要知道在构建您的项目时所需要构建或者运行的东西以便Gradle找到它们,我们将这些被导入的文件称作项目的依赖。另一方面,Gradle需要需要构建或者上传您的项目产出的东西,我们将这些由您的项目产出的文件称作项目的出版物

zip包 下载地址 http://gradle.android-studio.org/

http://gradle.android-studio.org/

没有更多推荐了,返回首页