HDU-6225 Little Boxes(大数相加)

                                         Little Boxes

                       Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
                                               Total Submission(s): 4039    Accepted Submission(s): 1529

Problem Description

Little boxes on the hillside.
Little boxes made of ticky-tacky.
Little boxes.
Little boxes.
Little boxes all the same.
There are a green boxes, and b pink boxes.
And c blue boxes and d yellow boxes.
And they are all made out of ticky-tacky.
And they all look just the same.

 Input

The input has several test cases. The first line contains the integer t (1 ≤ t ≤ 10) which is the total number of test cases.
For each test case, a line contains four non-negative integers a, b, c and d where a, b, c, d ≤ 2^62, indicating the numbers of green boxes, pink boxes, blue boxes and yellow boxes.

 Output

For each test case, output a line with the total number of boxes.

 Sample Input

4

1 2 3 4

0 0 0 0

1 0 0 0

111 222 333 404

Sample Output

10 0 1 1070

Source

2017ACM/ICPC亚洲区沈阳站-重现赛(感谢东北大学)

 

http://acm.hdu.edu.cn/showproblem.php?pid=6225

题意:

17年沈阳现场赛签到题。。

给你a,b,c,d,输出a+b+c+d。

思路:

一开始以为是大数,就用大数写的,其实long long就可以过。

大数直接套模板。

大数相加模板:

string sum(string s1,string s2)
{
    if(s1.length()<s2.length())
    {
        string temp=s1;
        s1=s2;
        s2=temp;
    }
    int i,j;
    for(i=s1.length()-1,j=s2.length()-1;i>=0;i--,j--)
    {
        s1[i]=char(s1[i]+(j>=0?s2[j]-'0':0));   //注意细节
        if(s1[i]-'0'>=10)
        {
            s1[i]=char((s1[i]-'0')%10+'0');
            if(i) s1[i-1]++;
            else s1='1'+s1;
        }
    }
    return s1;
}

代码:

大数的

#include<bits/stdc++.h>
using namespace std;

string sum(string s1, string s2)
{
	if(s1.length() < s2.length())
	{
		string temp = s1;
		s1 = s2;
		s2 = temp;
	}
	int i, j;
	for(i = s1.length() - 1, j = s2.length() - 1; i >= 0; i--, j--) {
		s1[i] = char(s1[i] + (j >= 0 ? s2[j] - '0' : 0));
		if(s1[i] - '0' >= 10){
			s1[i] = char((s1[i] - '0') % 10 +'0');
			if(i)	s1[i-1]++;
			else
				s1 = '1' + s1;
		}
	}
	return s1;
}
int main()
{
	int t;
	cin >> t;
	while(t--) {
		string a, b, c, d, s, ss,sss;
		cin >> a >> b >> c >> d;
		s = sum( a, b);
		ss = sum( s, c);
		sss = sum( ss, d);
		
		cout << sss <<  endl;
	}
	
	return 0;
} 

long long的

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
int main()
{
	int t;
	cin >> t;
	while(t--) {
		ll a, b, c, d;
		cin >> a >> b >> c >> d;
		ll sum = (a+b+c+d);
		cout << sum << endl;
	}
	
	return 0;
}

 

 

 

 

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值