A1044 Shopping in Mars (25分)【C语言】

A1044 Shopping in Mars (25分)【C语言】

原题链接

题目描述:
Shopping in Mars is quite a different experience. The Mars people pay by chained diamonds. Each diamond has a value (in Mars dollars M$). When making the payment, the chain can be cut at any position for only once and some of the diamonds are taken off the chain one by one. Once a diamond is off the chain, it cannot be taken back. For example, if we have a chain of 8 diamonds with values M$3, 2, 1, 5, 4, 6, 8, 7, and we must pay M$15. We may have 3 options:

  1. Cut the chain between 4 and 6, and take off the diamonds from the position 1 to 5 (with values 3+2+1+5+4=15).
  2. Cut before 5 or after 6, and take off the diamonds from the position 4 to 6 (with values 5+4+6=15).
  3. Cut before 8, and take off the diamonds from the position 7 to 8 (with values 8+7=15).

Now given the chain of diamond values and the amount that a customer has to pay, you are supposed to list all the paying options for the customer.

If it is impossible to pay the exact amount, you must suggest solutions with minimum lost.

输入格式:
Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤10 ​5​​ ), the total number of diamonds on the chain, and M (≤10 ​8​​ ), the amount that the customer has to pay. Then the next line contains N positive numbers D​1​​ ⋯D​N​​ (D​i​​ ≤10 ​3​​ for all i=1,⋯,N) which are the values of the diamonds. All the numbers in a line are separated by a space.

输出格式:
For each test case, print i-j in a line for each pair of i ≤ j such that Di + … + Dj = M. Note that if there are more than one solution, all the solutions must be printed in increasing order of i.

If there is no solution, output i-j for pairs of i ≤ j such that Di + … + Dj >M with (Di + … + Dj −M) minimized. Again all the solutions must be printed in increasing order of i.

It is guaranteed that the total value of diamonds is sufficient to pay the given amount.

输入样例1:

16 15
3 2 1 5 4 6 8 7 16 10 15 11 9 12 14 13

输出样例1:

1-5
4-6
7-8
11-11

输入样例2:

5 13
2 4 5 7 9

输出样例2:

2-4
4-5

实现代码:

#include <cstdio>

const int N = 100010;
int sum[N];
int n, S, nearS=100000010;

//返回在[L,R)内第一个大于x的位置
int upper_bound(int L, int R, int x){
	int left=L, right=R, mid;
	while(left<right){
		mid = (left+right) / 2;
		if(sum[mid]>x) right = mid;
		else left = mid + 1;
	}
	return left;
}

int main()
{
	scanf("%d %d", &n, &S);
	sum[0] = 0;
	for(int i=1; i<=n; ++i){
		scanf("%d", &sum[i]);
		sum[i] += sum[i-1];
	}
	for(int i=1; i<=n; ++i){ //枚举左端点 
		int j = upper_bound(i, n+1, sum[i-1]+S); //求右端点 
		if(sum[j-1]-sum[i-1]==S){ //查找成功 
			nearS = S; //最接近S的值就是S 
			break;
		}else if(j<=n && sum[j]-sum[i-1]<nearS){
			//存在大于S的解且小于nearS
			nearS = sum[j] - sum[i-1]; 
		}
	}
	for(int i=1; i<=n; ++i){
		int j = upper_bound(i, n+1, sum[i-1]+nearS);
		if(sum[j-1]-sum[i-1] == nearS){
			printf("%d-%d\n", i, j-1);
		}
	}
	
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值