A1015 Reversible Primes (20分)【C语言】

该博客介绍了一种特殊类型的质数——可逆质数,即在特定基数下,质数与其反转数也都是质数。文章提供了一个C语言的程序,用于检查给定的正整数N是否在基数D下是可逆质数,并提供了输入输出样例进行说明。
摘要由CSDN通过智能技术生成

A1015 Reversible Primes (20分)【C语言】

原题链接

题目描述:
A reversible prime in any number system is a prime whose “reverse” in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (<10 ​5​​ ) and D (1<D≤10), you are supposed to tell if N is a reversible prime with radix D.

输入格式:
The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

输出格式:
For each test case, print in one line Yes if N is a reversible prime with radix D, or No if not.

输入样例:

73 10
23 2
23 10
-2

输出样例:

Yes
Yes
No

实现代码:

#include <cstdio>
#include <cmath>

bool isPrime(int n){ //判断n是否为素数 
	if(n<=1) return false;
	int sqr = (int)sqrt(1.0*n);
	for(int i=2; i<=sqr; ++i){
		if(n%i==0) return false;
	}
	return true;
}

int main()
{
	int n, radix, d[110]; //数字,进制,存储进制转换的数组
	while(scanf("%d", &n)!=EOF){
		if(n<0) break; //读入负数时结束循环 
		scanf("%d", &radix);
		if(!isPrime(n)){ //如果这个数本身就不是素数,直接输出No 
			printf("No\n");
		}else{
			int len=0;
			do{ //进制转换 
				d[len++] = n % radix;
				n /= radix;
			}while(n!=0);
			for(int i=0; i<len; ++i){
				n = n*radix + d[i]; //实现倒序 并转换为十进制 
			}
			if(isPrime(n)) printf("Yes\n");
			else printf("No\n");
		}
	} 
	
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值