POJ2002Squares(哈希)

Squares
Time Limit: 3500MS Memory Limit: 65536K
Total Submissions: 18956 Accepted: 7311

Description

A square is a 4-sided polygon whose sides have equal length and adjacent sides form 90-degree angles. It is also a polygon such that rotating about its centre by 90 degrees gives the same polygon. It is not the only polygon with the latter property, however, as a regular octagon also has this property. 

So we all know what a square looks like, but can we find all possible squares that can be formed from a set of stars in a night sky? To make the problem easier, we will assume that the night sky is a 2-dimensional plane, and each star is specified by its x and y coordinates. 

Input

The input consists of a number of test cases. Each test case starts with the integer n (1 <= n <= 1000) indicating the number of points to follow. Each of the next n lines specify the x and y coordinates (two integers) of each point. You may assume that the points are distinct and the magnitudes of the coordinates are less than 20000. The input is terminated when n = 0.

Output

For each test case, print on a line the number of squares one can form from the given stars.

Sample Input

4
1 0
0 1
1 1
0 0
9
0 0
1 0
2 0
0 2
1 2
2 2
0 1
1 1
2 1
4
-2 5
3 7
0 0
5 2
0

Sample Output

1
6
1

Source


#include<stdio.h>
#include<string.h>
#define maxn 2500
bool vis[maxn<<1][maxn<<1];
int xx[maxn];
int yy[maxn];

int main()
{
    int n,i,j;
    int x1,y1,x2,y2,x3,y3,x4,y4;

    while(~scanf("%d",&n),n)
    {
        memset(vis,0,sizeof(vis));
        int cnt = 0;

        for(i = 1; i <= n;i++)
        {
            scanf("%d%d",&xx[i],&yy[i]);
           // printf("---\n");
            vis[xx[i]+maxn][yy[i]+maxn]=1;
        }

        for( i = 2; i<=n; i++)
        {
                x1=xx[i];
                y1=yy[i];
            for( j = 1; j<i; j++)
            {
                 x2=xx[j];
                 y2=yy[j];

                x3=x1+(y1-y2);
                y3= y1-(x1-x2);
                x4=x2+(y1-y2);
                y4= y2-(x1-x2);
                if(vis[x3+maxn][y3+maxn]&&vis[x4+maxn][y4+maxn])
                cnt++ ;
                x3=x1-(y1-y2);
                y3= y1+(x1-x2);
                x4=x2-(y1-y2);
                y4= y2+(x1-x2);
                if(vis[x3+maxn][y3+maxn]&&vis[x4+maxn][y4+maxn])
                cnt++ ;
            }
        }

        printf("%d\n",cnt>>2);
    }
return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值