poj 3292 Semi-prime H-numbers(筛法~)

Semi-prime H-numbers
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8736 Accepted: 3825

Description

This problem is based on an exercise of David Hilbert, who pedagogically(教学法上) suggested that one study the theory of 4n+1 numbers. Here, we do only a bit of that.

An H-number is a positive(积极的) number which is one more than a multiple of four: 1, 5, 9, 13, 17, 21,... are the H-numbers. For this problem we pretend that these are the only numbers. The H-numbers are closed under multiplication(乘法).

As with regular integers(整数), we partition(分割) the H-numbers into units, H-primes, and H-composites. 1 is the only unit. An H-number h is H-prime if it is not the unit, and is the product of two H-numbers in only one way: 1 × h. The rest of the numbers are H-composite.

For examples, the first few H-composites are: 5 × 5 = 25, 5 × 9 = 45, 5 × 13 = 65, 9 × 9 = 81, 5 × 17 = 85.

Your task is to count the number of H-semi-primes. An H-semi-prime is an H-number which is the product of exactly two H-primes. The two H-primes may be equal or different. In the example above, all five numbers are H-semi-primes. 125 = 5 × 5 × 5 is not an H-semi-prime, because it's the product of three H-primes.

Input

Each line of input(投入) contains an H-number ≤ 1,000,001. The last line of input contains 0 and this line should not be processed.

Output

For each inputted H-number h, print a line stating h and the number of H-semi-primes between 1 and h inclusive(包括的), separated by one space in the format shown in the sample(样品).

Sample Input

21 
85
789
0

Sample Output

21 0
85 5
789 62

题意:先定义一些数:

1、H-number:可以写成4k+1的数,k为整数

2、H-primes:只能分解成1*本身,不能分解成其他的H-number

3、H-semi-primes:能够恰好分解成两个H-primes的乘积,且只能是两个数的乘积。输出1-N之间有多少个H-semi-primes。

解法:类似于筛法求素数。先筛出H-primes,然后再枚举每两个H-primes的乘积,筛出H-semi-primes。最后统计1-Max之间的H-semi-primes的个数,保存在数组中。

#include<stdio.h>

int h[1000001];
int n;
void slove()
{
    int i,j,s,count;
    for( i = 5;i <=1000001; i+=4)
        for( j = 5; j <= 1000001; j+=4)
    {
        s=i*j;
        if(s>1000001) break;
        if(h[i]==0&&h[j]==0)
        {
            h[s] = 1;
        }
        else h[s]=-1;
    }
    count = 0;
    for(i=1;i<=1000001;i++)
    {
        if(h[i]==1)
        {
            h[i]=++count;
        }
        else h[i] = count;
    }
}
int main()
{

    int i,j;

//    for( i = 5;i<=100; i++)
//    if(h[i]==1)
//        printf("%d ",h[i]);
       slove();
    while(~scanf("%d",&n),n)
    {

//
//        int sum=0;
//        for(i=5;i<=n;i++)//这样会超时  所以 ……
//            if(h[i]==1)
//              sum++;
        printf("%d %d\n",n,h[n]);
    }
    return 0;
}



                
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值