数据结构实验之二叉树五:层序遍历(队列)

数据结构实验之二叉树五:层序遍历

Time Limit: 1000MS  Memory Limit: 65536KB
Problem Description

已知一个按先序输入的字符序列,如abd,,eg,,,cf,,,(其中,表示空结点)。请建立二叉树并求二叉树的层次遍历序列。

Input
  输入数据有多行,第一行是一个整数t (t<1000),代表有t行测试数据。每行是 一个长度小于50个字符的字符串。
Output
  输出二叉树的层次遍历序列。
Example Input
2
abd,,eg,,,cf,,,
xnl,,i,,u,,
Example Output
abcdefg
xnuli
#include<stdio.h>
struct node
{
    int data;
    struct node *l,*r;
};
char s[1110];
struct node *p[1110];
int cnt;
struct node *creat()
{
    struct node*t;
    if(s[++cnt]==',')
    {
        t=NULL;
    }
    else
    {
        t= new node;
        t->data=s[cnt];
        t->l=creat();
        t->r=creat();
    }
    return t;
};
void cenci(struct node *root)
{
    int tail=0,head=0;
    p[tail++] = root;
    while(tail>head)
    {
        if(p[head])
        {
            printf("%c",p[head]->data);
            p[tail++]=p[head]->l;
            p[tail++]=p[head]->r;
        }
        head++;
    }

}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        cnt=-1;
        scanf("%s",s);
        struct node* root;
        root = creat();
       cenci(root);
       printf("\n");

    }
return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值