数据结构实验之二叉树七:叶子问题
Time Limit: 1000MS Memory Limit: 65536KB
Problem Description
已知一个按先序输入的字符序列,如abd,,eg,,,cf,,,(其中,表示空结点)。请建立该二叉树并按从上到下从左到右的顺序输出该二叉树的所有叶子结点。
Input
输入数据有多行,每一行是一个长度小于50个字符的字符串。
Output
按从上到下从左到右的顺序输出二叉树的叶子结点。
Example Input
abd,,eg,,,cf,,,
xnl,,i,,u,,
Example Output
dfg
uli
Hint
#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
using namespace std;
char s[110];
int cnt;
int num;
struct node
{
char x;
node *l, *r;
};
node *create()
{
node *rt;
if(s[cnt++] == ',')
{
return NULL;
}
rt = new node();
rt->x = s[cnt - 1];
rt->l = create();
rt->r = create();
return rt;
}
void printLeaf(node *rt)
{
queue<node *>q;
q.push(rt);
while(!q.empty())
{
node *tmp = q.front();
q.pop();
if(!tmp)
continue;
if(!tmp->l && !tmp->r)
{
printf("%c", tmp->x);
}
if(tmp->l)
q.push(tmp->l);
if(tmp->r)
q.push(tmp->r);
}
printf("\n");
}
/*
void printLeaf1(node *rt)
{
node *q[110];
int head =0, tail = 0;
q[tail++] = rt;
while(head < tail)
{
node *tmp = q[head++];
if(!tmp) continue;
if(!tmp->l && !tmp->r)
{
printf("%c", tmp->x);
}
if(tmp->l)
q[tail++] = tmp->l;
if(tmp->r)
q[tail++] = tmp->r;
}
printf("\n");
}
*/
int main()
{
while(~scanf("%s", s))
{
cnt = 0;
node *rt = create();
printLeaf(rt);
}
return 0;
}