数据结构实验之二叉树七:叶子问题

数据结构实验之二叉树七:叶子问题

Time Limit: 1000MS Memory Limit: 65536KB

Submit Statistic

Problem Description

已知一个按先序输入的字符序列,如abd,,eg,,,cf,,,(其中,表示空结点)。请建立该二叉树并按从上到下从左到右的顺序输出该二叉树的所有叶子结点。

Input

 输入数据有多行,每一行是一个长度小于50个字符的字符串。

Output

 按从上到下从左到右的顺序输出二叉树的叶子结点。

Example Input

abd,,eg,,,cf,,,
xnl,,i,,u,,

Example Output

dfg
uli

Hint

#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
using namespace std;
char s[110];
int cnt;
int num;
struct node
{
    char x;
    node *l, *r;
};

node *create()
{
    node *rt;
    if(s[cnt++] == ',')
    {
        return NULL;
    }
    rt = new node();
    rt->x = s[cnt - 1];
    rt->l = create();
    rt->r = create();
    return rt;
}

void printLeaf(node *rt)
{
   queue<node *>q;
   q.push(rt);

   while(!q.empty())
   {
       node *tmp = q.front();
       q.pop();
       if(!tmp)
          continue;
       if(!tmp->l && !tmp->r)
       {
           printf("%c", tmp->x);
       }
       if(tmp->l)
        q.push(tmp->l);
       if(tmp->r)
        q.push(tmp->r);
   }
   printf("\n");
}

/*
void printLeaf1(node *rt)
{
    node *q[110];
    int head =0, tail = 0;
    q[tail++] = rt;
    while(head < tail)
    {

        node *tmp = q[head++];
        if(!tmp) continue;
        if(!tmp->l && !tmp->r)
       {
           printf("%c", tmp->x);
       }
       if(tmp->l)
        q[tail++] = tmp->l;
       if(tmp->r)
        q[tail++] = tmp->r;
    }
    printf("\n");
}
*/
int main()
{
    while(~scanf("%s", s))
    {
        cnt = 0;
        node *rt = create();
        printLeaf(rt);

    }

    return 0;
}

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值